PDA

View Full Version : How can I compile css using sass?



meshulro
20 Jun 2010, 10:23 AM
Trying to compile tabs.scss gave me this error -

sass tabs.scss tabs.ccs

Syntax error: Undefined mixin 'linear-gradient'.
on line 59 of ././_ext-base.scss, in `linear-gradient'
from line 59 of ././_ext-base.scss, in `bg_gradient'
from line 81 of tabs.scss
Use --trace for backtrace.

Thank you,
Roy

TommyMaintz
20 Jun 2010, 2:51 PM
Hi, we are planning on writing a blog post or tutorial about how to customize the theme using sass soon. It looks like you haven't installed compass which is a framework on top of sass that we are using. For both sass and compass you need to install the --pre version. Let me know if you run into any problems.

diederikveelo
31 Aug 2010, 12:52 AM
Hi Tommy,

I'm having the same problems trying to compile the scss with sass. I have upgraded both sass and compass but it keeps raising the same error to me as Roy has. Could you please shed some light on this?

Your help is much appreciated!

Cheers,
Diederik.

gabrielstuff
31 Aug 2010, 5:19 PM
Here : http://www.sencha.com/forum/showthread.php?107412-CSS-styling-(button-after-before...)
I think you will find what you need.

diederikveelo
2 Sep 2010, 5:47 AM
Hi Gabriel,

Thanks for your reply but unfortunately it didn't solve my issue. I have been struggling with this for over three days now and can't seem to get sass properly running. It keeps sending me an error when I try to compile the button.scss file into an css file. It gives me the following error:

error sass/src/./_ext-base.scss (Line 55: Undefined mixin 'linear-gradient'.)

When I run sass with the --watch command it gives me two warnings which I believe are old. If I look at the _ext-base.scss file I believe the two are explicitly imported.


$ sass --watch sass/src:css/src
>>> Sass is watching for changes. Press Ctrl-C to stop.
WARNING: Neither compass/css3.sass nor .scss found. Using compass/css3.css instead.
This behavior is deprecated and will be removed in a future version.
If you really need compass/css3.css, import it explicitly.

WARNING: Neither blueprint/typography.sass nor .scss found. Using blueprint/typography.css instead.
This behavior is deprecated and will be removed in a future version.
If you really need blueprint/typography.css, import it explicitly.

>>> Change detected to: /Library/WebServer/Documents/resources/sass/src/button.scss
WARNING: Neither compass/css3.sass nor .scss found. Using compass/css3.css instead.
This behavior is deprecated and will be removed in a future version.
If you really need compass/css3.css, import it explicitly.

WARNING: Neither blueprint/typography.sass nor .scss found. Using blueprint/typography.css instead.
This behavior is deprecated and will be removed in a future version.
If you really need blueprint/typography.css, import it explicitly.

error sass/src/./_ext-base.scss (Line 55: Undefined mixin 'linear-gradient'.)


I'm running haml-3.0.18, and compass-0.10.5
ruby 1.8.6 (2009-06-08 patchlevel 369) [universal-darwin9.0]

Your help is very much appreciated!
Best regards,
Diederik.

diederikveelo
2 Sep 2010, 6:09 AM
Ah... it seems that I should not use sass --watch but compass watch... that seems to work on my test project so yeah! :-)

Thanks for your help, sencha here I come.

diederikveelo
2 Sep 2010, 6:20 AM
wel... it's a bit more complicated. If I try to play with the button.scss from sencha it raises another error on me, but by commenting out the require 'compass-colors' in the config.rb file inside the sass folder it seems to work fine. I can't see any differences in the demo, but maybe I'm doing something stupid.

Diederik.

jnicora
29 Sep 2010, 9:51 AM
Is there a tutorial up for this yet?

jnicora
29 Sep 2010, 2:28 PM
Sorry, I forgot about searching =)

http://www.sencha.com/blog/2010/06/29/getting-sassy-with-css/

in case anyone else needs it