PDA

View Full Version : Sencha Touch on iPhone v1 / iPod touch v1 ?



palnap
1 Jul 2010, 8:09 AM
Hi folks !

I read few days ago Apple will not port iOS 4 on oldest devices like iPhone v1 or iPod touch v1. Does it mean these devices will never be HTML 5 enabled?

In other words, will Sencha Touch works fine on them? If not, is it planned to port Sencha Touch to the previous Safari Mobile versions?

Thanks for your answers !

TommyMaintz
1 Jul 2010, 1:29 PM
Unfortunately the first generation iPhones and iPods don't have the capabilities we need in order to give the user a good experience. Thus we don't have plans to support the first generation. For now we are focussing on iOS 3.0+ and Android 2.1+. They both support all the css3 and html5 capabilities that we need to create enticing applications with a good user experience.

palnap
2 Jul 2010, 12:01 AM
Ok, I'm relieved, I thought only iOS 4 was HTML5 enabled !

bone
2 Jul 2010, 12:51 AM
I have a 1gen iPod Touch and havent updated to iOS 4 and it works like a charm

ficeto
28 Oct 2010, 5:30 PM
I have an iPhone 3G and complex UIs run really slow. Up to the point where the application is unusable. So far I trace it back visibility and touch event's and checks. I even get execution timeouts, so I had to ditch lots of card panels and create a hacked one that keeps only one child or the app will not even work. None of those exist on a simulator or a desktop browser, on those it flies :)