PDA

View Full Version : [CLOSED] GWT compiler error in ChartModel using 2.2.0 final?



crehbein
7 Sep 2010, 8:43 AM
I find it hard to believe I'm the only one with this problem, but I'm getting the following error message when GWT-compiling and/or running our app using 2.2.0 (the jar downloaded from the Sencha website, not what's in SVN):

[ERROR] Errors in 'jar:file:/C:/Documents%20and%20Settings/crehbein/.m2/repository/com/extjs/gxt/gxt/2.2/gxt-2.2.jar!/com/extjs/gxt/charts/client/model/ChartModel.java'
[ERROR] Line 494: Type mismatch: cannot convert from int to Double
[ERROR] Line 495: Type mismatch: cannot convert from int to Double

Often the GWT compiler sometimes picks up things that the Eclipse compiler doesn't care about... this error seems to be completely internal to the 2.2.0 code and not related to any of our own.. the fix should be:

- provider.maxYValue = 0;
- provider.minYValue = 0;

+ provider.maxYValue = 0d;
+ provider.minYValue = 0d;

Right?

crehbein
7 Sep 2010, 8:55 AM
Ah, nevermind its not an error.. I had old ChartModel code still in my jar file with Doubles instead of doubles.

sven
7 Sep 2010, 8:57 AM
There is no Double involved, only a primative double type.

Can you make sure that you updated the gxt.jar everywhere you reference it?

sven
7 Sep 2010, 9:03 AM
Ah, nevermind its not an error.. I had old ChartModel code still in my jar file with Doubles instead of doubles.

So i can close this?

crehbein
7 Sep 2010, 9:16 AM
Please do.. :)

sven
7 Sep 2010, 9:28 AM
Done ;)