PDA

View Full Version : Youtube appears as "objects" stuck to screen



directx0000
11 Sep 2010, 6:08 PM
Hi everyone, I've come across a weird experience with youtube embed. When you have a Ext.Panel with its html property containing embedded codes from youtube, the preview box appears but -- it DOESN'T scroll with the screen (if you have a long html doc) and seems "stuck" at screen positioning no matter what. This is most notable when there's multiple items of such.

I've tried applying css position (fixed, absolute etc..) attributes to the div container it hosts but no avail. Any help anyone? Thank you!

evant
11 Sep 2010, 7:42 PM
Are you embedding flash objects? Because that's not going to work on iPhone/iPad anyway.

directx0000
11 Sep 2010, 8:35 PM
I copied the embed code directly from Youtube's embed feature; though it has Flash related variables it actually loads and can play videos directly. Probably HTML5 code is passed when the user-agent is detected as iPhone.

You see I was trying to develop a page that is similar to the Timeline part in the "Guide" example -- rather than list of tweets but a list of youtube video objects than can be clicked. It works initially, but after viewing the video and returning back to the screen, the object gets "stuck", like a topmost window blocking other content... :(

RandyMcMillan
12 Sep 2010, 2:31 PM
The problem is in how UIWebView handles YouTube objects.

DigiDood
4 Oct 2010, 2:30 PM
I'm seeing the same thing too. wondering if anyone has a workaround. It also "sticks" on the screen when you animate a new card in and out with a youtube embed on the screen.