PDA

View Full Version : [NOREPRO] Sencha Animator OS X 10.5.8 login failed



idham
29 Oct 2010, 6:19 PM
Dear members, I've recently downloaded the developer preview of Sencha Animator for OS X and I already have an account of Sencha Forum but when I tried to login several times the login information keep disappear from the login box information.

Does anyone having the same problem ? how to resolve it ?
Does connectivity behind proxy has something to do with it ?


thankz

jarrednicholls
29 Oct 2010, 6:27 PM
idham, I think there was a cachefly caching issue. Can you download 0.91 .dmg and reinstall, then try again? http://www.sencha.com/products/animator/download.php sorry for the inconvenience.

P.S. If your proxy information is configured in the OS X Network Preferences, it should be picked up automatically.

idham
29 Oct 2010, 7:47 PM
a few minutes a go I've done re downloaded SenchaAnimator-0.91.dmg and it still came out the same failed login (disappear login info).

anyway thanks for replying

jarrednicholls
30 Oct 2010, 2:36 AM
Make sure you are actually downloading it and your browser didn't simply cache it. I will post an MD5 soon. You still have an old copy.

MD5 = 43df425562b9d1c4df0b0e5884373a1d

idham
30 Oct 2010, 3:51 AM
the newer version get a response that said unable to communicate with Sencha Animator license server

jarrednicholls
30 Oct 2010, 4:01 AM
Ok thanks for letting me know idham. I'm working with a Leopard user to resolve this issue and I'll post a sticky thread with a solution and/or a new download ASAP.

idham
30 Oct 2010, 4:04 AM
I'm Using 32 bit Leopard, is that the problem ? if that was the problem maybe I should use the Linux Version

jarrednicholls
30 Oct 2010, 4:14 AM
If by "32-bit Leopard" you mean it's running in 32-bit kernel mode, then that should be ok (I think that's the default to most all OS X installations, Snow Leopard included..?) The application itself is 64-bit, and it has universal OpenSSL binaries bundled with it. I think the issue is a shared library pathing issue.

If you have that Linux machine, then by all means, definitely try it out on Linux while you wait for a fix :-)

jarrednicholls
30 Oct 2010, 7:22 PM
Try this one out: http://dl.dropbox.com/u/12081268/SenchaAnimator-0.91.dmg

idham
31 Oct 2010, 6:28 AM
http://ilkomers.com/redmine/attachments/download/1/error_low.jpg
this is the screenshot of the error for the newer version you gave me.

idham
31 Oct 2010, 6:31 AM
oh yeah, and the MD5 for the latest download are = 44613bfe816e58f09bd24f0afaa30f2a in case I did a mistake in downloading it

thanks

jarrednicholls
31 Oct 2010, 7:18 AM
Ok thanks for the feedback. You aren't behind a proxy server or anything, right?

This lastest build is against the 10.5 SDK, and is hard linked to OpenSSL. In other words, if the compatible OpenSSL library wasn't on your system, the application would crash. So, this cannot be an issue with finding and loading OpenSSL anymore.

The investigation continues...

jarrednicholls
31 Oct 2010, 8:10 AM
I just tested on Leopard 10.5.1 and it worked. I will upgrade to 10.5.8 and see if it still works.

idham
31 Oct 2010, 8:40 AM
I just tested on Leopard 10.5.1 and it worked. I will upgrade to 10.5.8 and see if it still works.

by using which version of the apps ?
FYI I'm not accessing from behind any firewalls or proxies
I'm using Macbook Pro 4.1 penryn with 2.4 Ghz intel Core 2 Duo on Leopard 10.5.8
and


Nafira:~ idh4m$ openssl version
OpenSSL 0.9.7l 28 Sep 2006

jarrednicholls
31 Oct 2010, 8:47 AM
The last version. I didn't check prior builds on this instance. The instance is in the middle of the upgrade to 10.5.8, running installer scripts. I'll try again once it is complete.

jarrednicholls
31 Oct 2010, 9:20 AM
After upgrading to 10.5.8, it does not work. To the interwebs...

cye
31 Oct 2010, 12:56 PM
I'm getting the very same problem running 0.91 on leopard. I tried downloading and installing the dmg from the dropbox link you posted but still no luck.

cye
31 Oct 2010, 1:08 PM
the error i'm getting is "unable to communicate with Sencha animator license server"

jarrednicholls
1 Nov 2010, 4:58 AM
Thanks cye. I will be posting (yet another) version today. Apple released a security update earlier this year, which broken OpenSSL for 10.5.8 and others. Yet they did not update their 10.5 SDK OpenSSL headers to reflect the security change.

We'll have this resolved ASAP.

jarrednicholls
1 Nov 2010, 9:14 AM
New release posted, see this thread: http://www.sencha.com/forum/showthread.php?114234-OS-X-32-bit-Leopard-Compatible-Build

Make sure to check the MD5 so you know you didn't receive a cached download.

peterjjohnson
4 Nov 2010, 1:01 PM
I am having the same problem on Linux. Is this a Windows versus *NIX issue?

jarrednicholls
4 Nov 2010, 1:12 PM
Hi Peter,

The issue on OS X Leopard (10.5.8) was OpenSSL recognition. On Linux and Windows, OpenSSL binaries are deployed with the application and should be picked up and recognized.

Are you behind a proxy server? The other issue that might cause a failed connection is a proxy server that cannot be automatically "understood" by the application. Windows and OS X provide automatic proxy solutions, but there is no such capability for Linux. We'll be adding manual proxy configuration support before the 1.0 release.

If you aren't behind a proxy server, what distribution of Linux (and its version) are you running?

peterjjohnson
4 Nov 2010, 1:20 PM
I'm not behind a proxy server. I am using a home router for a wireless network, but I haven't had any other problems like this. I'm using Slackware 12.0; I'm not having problems with any other (https) sites.

jarrednicholls
4 Nov 2010, 1:26 PM
Wow, I haven't used Slackware in like 5 years! :-)

Well we definitely don't build against Slackware, so it's entirely possible that our packaged OpenSSL binaries are not compatible with Slackware's libc/libz. Do you have OpenSSL installed on your system from Slackware's package manager? We require version 0.9.8...if Slackware has a 0.9.8 build of OpenSSL available in its package manager, perhaps installing that will resolve the issue.

Side Note: we build on Ubuntu Hardy Heron (8.04), which was released in April 2008. Slackware 12 was released in January 2008. Some of the software dependencies might be too "new" for Slackware 12 to handle. The fact that the application is launching for you is a very good sign, and I think we're just at the point of getting OpenSSL to work.

peterjjohnson
4 Nov 2010, 1:31 PM
As near as I can tell, I have 9.8 installed.

jarrednicholls
4 Nov 2010, 1:39 PM
Where are your OpenSSL libraries installed? /usr/lib? /usr/local/lib?

peterjjohnson
5 Nov 2010, 7:35 AM
They seem to be present in a number of places under /usr/lib: /usr/lib, /usr/lib/seamonkey, /usr/lib/thunderbird, /usr/lib/firefox. In /usr/lib, the main library is /usr/lib/libssl.so.0.9.8; that's where the link /usr/lib/libssl.so points. In the mozilla directories, it's named libssl3.so.

jarrednicholls
5 Nov 2010, 8:03 AM
You can try making a backup of libcrypto.so.0.9.8 and libssl.so.0.9.8 under /usr/lib and create symbolic links to the libs in your animator installation directory. For example, if you installed at /home/peter/SenchaAnimator, you can run these commands (as root or using sudo):



$: mv /usr/lib/libcrypto.so.0.9.8 /usr/lib/libcrypto.so.0.9.8.bak && ln -s /home/peter/SenchaAnimator/libcrypto.so.0.9.8 /usr/lib/libcrypto.so.0.9.8
$: mv /usr/lib/libssl.so.0.9.8 /usr/lib/libssl.so.0.9.8.bak && ln -s /home/peter/SenchaAnimator/libssl.so.0.9.8 /usr/lib/libssl.so.0.9.8


The application is finding your OpenSSL lib before it finds the one located in the animator's install dir, and your version may not be (for some reason) binary compatible. Creating a symbolic link in /usr/lib that points to the animator directory might solve the issue. If it does not, then I have another solution to getting you up and running that doesn't involve fixing OpenSSL.

We'll be sure to hard link the OpenSSL libs to the application rather than dynamically resolve the OpenSSL symbols, before the 1.0 release. Then we won't have this type of issue.