PDA

View Full Version : setLayoutNeeded signature error?



rluk
5 Jan 2011, 11:00 AM
I know this has been asked before http://www.sencha.com/forum/showthread.php?92358-CLOSED-GXT-2.1.1-strange-BUG&highlight=setLayoutNeeded+signature, but I wonder if a solution has been found yet?

I try to create this as described in the setting up your first EXT project in Eclipse: http://www.sencha.com/blog/2010/11/10/setting-up-your-first-ext-gwt-project-in-eclipse/
public class HelloGXT implements EntryPoint{
@Override
public void onModuleLoad() {
MessageBox.info("Message", "Hello World!!", null);
}
}

And when I run it, I got this error:

java.lang.VerifyError: (class: com/extjs/gxt/ui/client/widget/Container, method: setLayoutNeeded signature: (Z)V) Illegal constant pool index
at com.extjs.gxt.ui.client.widget.MessageBox.getDialog
....
....

I am using jdk1.6.0_03, eclipse 3.6, GXT 2.2.1, GWT 2.1.0, should I change to a newer jdk?

Thanks for your help!

rluk
5 Jan 2011, 12:48 PM
I am answering my own question: it's working with jdk1.6.0_18.