PDA

View Full Version : Theming Issue



dorgan
28 Jan 2011, 7:04 PM
I have the following in my scss file:

$button-radius: 15px;

When i try to compile this I get the following error:

error lps.scss (Line 123: Incompatible units: 'em' and 'px'.)

Any help is appreciated.

AndreaCammarata
29 Jan 2011, 1:09 AM
Hi dorgan.
I took a look at your issue and I notice that "$button-radius" property accept only ".em" values.
In fact, if you take a look at the "_button.scss" inside the Sencha widget themes, you will notice that at the line 123, it tries to calculate the button mask offset by a simple math operation



$mask-offset: $button-radius - $overlap-width - $button-stroke-weight + $shadow-width - .02em;
So, setting the $button-radius with 'px' value it is not able to calculate this value because it has incompatible units.

So, if you want change your button radius, try to use .em value like



$button-radius: .8em;
Hope this helps.

dorgan
29 Jan 2011, 8:07 PM
OK i changed my config to use 1.5 em just as a starter and nothing seems to have changed....

AndreaCammarata
30 Jan 2011, 12:41 AM
OK i changed my config to use 1.5 em just as a starter and nothing seems to have changed....

Just for testing pupose try with highter value like .8em and see if something change.
It works for me.

dorgan
30 Jan 2011, 4:37 PM
I think maybe I am setting the wrong value...what should I be changing for the tabs for a tab Panel....I've also tried $tab-radius and that didnt seem to have an effect

AndreaCammarata
31 Jan 2011, 12:27 AM
If you have to edit tab style, try to edit these variable value:

$tabs-top-height
$tabs-bottom-radius

Hiope this helps.