PDA

View Full Version : [CLOSED] can't dismiss an autocorrect suggestion in iPad



adana325
17 Mar 2011, 5:49 AM
If I leave auto correct turned on, on the iPad I find that I can not tap the x in the suggested correction in order to not use it. If there is a suggestion I WILL use it. (I know I can turn auto correct off...but I'd like to have it enabled). Here is a simple form that shows the problem.


Ext.setup({
onReady: function(){
new Ext.form.FormPanel({
fullscreen: true,
scroll: 'both',

items: [{
xtype: 'textfield',
label: 'field1',
name: 'field1'
}, {
xtype: 'textfield',
label: 'field2',
name: 'field3'
}, {
xtype: 'textareafield',
name: 'content',
maxRows: 12,
}, ],
});
}
});

Gardener
4 Jul 2011, 3:30 AM
Any news on this problem? I have also been having this problem for quite some time. Still exists in Sencha Touch v1.1.0 on iPad 2 iOS 4.3

adana325
4 Jul 2011, 5:15 AM
I never got a response to this and ended up shutting off autocorrect. I'd love to turn it back on if we get a fix!

Gardener
5 Jul 2011, 3:39 AM
Guess I'll have to turn off auto-correct for the time being as well. =(

suzzer99
27 Jul 2011, 4:03 PM
We are seeing this same problem on iPhone with 4.3.3. The kitchen sink is doing it as well.

jdb
23 Sep 2011, 7:53 AM
I also confirm this, on iPhone and iPad.
If you tap on the "x" it won't react, you need to tap over the field itself (but a normal user will never guess that) Other than that IT CAN'T be dismissed. It screws you up if you need to type a different text.

Is there a workaround? can auto-correction be disabled for all <input> fields?

EDIT: found this, will try: http://www.sencha.com/forum/showthread.php?105425-COMPLETED-175-Add-autocorrect-config-to-Ext.form.Field&highlight=autocorrect

EDIT 2: Works.

DragoslaV
27 Sep 2011, 12:36 AM
We have noticed that you cant dismiss corrections because of the CSS3 transform used for scrolling.

See my bug here: http://www.sencha.com/forum/showthread.php?147158-iPad-Scrolling-below-the-fold-will-disable-native-magnifier-and-selecting-text