PDA

View Full Version : Ext & application files are loaded separately althougth of using app-all.js



Antronak
15 Jul 2011, 12:42 AM
Hi,

I have problem with my Ext application in production mode.

This is debug-mode html.


<!DOCTYPE html>
<html>
<head>
<meta charset="utf-8">
<link rel="stylesheet" href="extjs/resources/css/ext-all-gray.css" />
</head>
<body>
<script src="extjs/ext-debug.js"></script>
<script src="app.js"></script>
</body>
</html>

I'm using Ext.require & Ext.syncRequire to load classes.

This is production-mode html:

<!DOCTYPE html>
<html>
<head>
<meta charset="utf-8">
<link rel="stylesheet" href="/extjs/resources/css/ext-all-gray.css" />
</head>
<body>
<script src="extjs/ext.js"></script>
<script src="app-all.js"></script>
</body>
</html>

Every classes and app.js are in app-all.js, but every classes are still loaded separately from disk.

What am I doing wrong?

Thanks i advance!

climent05
16 Jul 2011, 3:40 AM
Where your calling the javascript function in the code.

try to call the classes in the html code from classes given in the javascript


Cegonsoft Corporate Training (http://www.cegonsoft.com/corporatetraining.php)

edspencer
19 Jul 2011, 10:57 PM
Are you still seeing this behavior? Did you wrap your startup code inside an Ext.onReady call?

Antronak
22 Jul 2011, 12:36 AM
It's OK. My fault when making .jsp3 file and building application.

edspencer
22 Jul 2011, 2:36 PM
Cool, glad it worked out

spillo491
24 Oct 2011, 4:31 AM
How did you resolve please ? I have the same problem ....