PDA

View Full Version : Ext Core ie9 support



eli_s
1 Aug 2011, 5:06 AM
Is there a version of Ext-Core that supports ie9 coming?

The current latest version reports ie9 as ie6 and all animations are broken.

I've tried messing with the browser detection code, however I couldn't get it working.

Even when I hard-coded Ext.isIE8 = true (since setting ie9 to ie8 rendering mode make anims work) and no-go :((

BTW have searched through the forums and Google without finding any answers. Strange that no one is really even talking about it???

Mycoding
7 Aug 2011, 6:00 AM
Please tell what kind of problem do you face in IE9?
Is it shown in different way?

When I did NodeJS framework on base of Ext Core and look trough all code of Ext Core very attentively
I din't face any IE tricks for html only webkit.

If you write Ext Core site may I look at it?

feyyaz
28 Feb 2013, 7:01 AM
I had the same problems wit the outdated ext core. i don't know if i did it right but i compiled with the JSBuilder from sencha a new ext core out of ExtJS 3.4 which is IE9 compatible it could be that some stuff is missing because i had to add Ext-more.js out of ExtJS core to make the new core workable with my project. so far everything that wasn't working with the old ext core in IE9 is working now. give it a try and you will see.

http://www.paob.de/externlink/sencha/ext-core3.4.zip