PDA

View Full Version : Ext GWT 2.2.5 Now Available



darrellmeyer
19 Sep 2011, 12:41 PM
Ext GWT 2.2.5 is now available. This includes over 45 bug fixes. See the release notes (http://dev.sencha.com/deploy/gxt-2.2.5/release_notes.html).

Grab a copy on the download (http://www.sencha.com/products/extgwt/download/) page.

behrangsa
24 Sep 2011, 11:25 PM
Would it be possible to upload the releases simultaneously to Maven Central please? Right now the most recent version available on Maven Central is 2.2.0.

EDIT: I found ExtJS 2.2.4 inside the https://oss.sonatype.org/content/repositories/comextjs-094 repository. Is this the official repository for getting ExtJS 2.x?

Thanks,
Behrang

sven
25 Sep 2011, 12:02 AM
We do not maintain the GXT 2 release in maven central. GXT 3 will be the first version maintained by us in maven central.

apandey1
17 Oct 2011, 2:34 AM
I see three jars in release. Seems they are based on GWT release. We use GWT 2.0.4 version. I wanted to know which one is most compatible with EXT GWT 2.2.5.
Is it gxt-2.2.5-gwt22.jar or gxt-2.2.5-gwt2.jar.

sven
17 Oct 2011, 6:08 AM
You should use the gwt2.jar file

apandey1
17 Oct 2011, 6:17 AM
Thanks for reply, I get this error when I use GWT 2.0.4 with EXT GWT 2.2.5
Errors in 'jar:file: .m2/repository/com/extjs/gxt/
.2.5/gxt-2.2.5.jar!/com/extjs/gxt/ui/client/GXT.java'
[ERROR] Line 169: Failed to resolve 'com.extjs.gxt.ui.client.messa
es.XMessages' via deferred binding

However I never got this error with our current version of EXT GWT 2.2.0



If I use GXT jar with 22 suffix I get this error:

java.lang.IncompatibleClassChangeError: Found class com.google.gwt.core.e
xt.typeinfo.JClassType, but interface was expected
[INFO] at com.extjs.gxt.ui.rebind.core.TemplatesGenerator$SourceGenerator.valid
ateType(TemplatesGenerator.java:142)



Thanks
Amit

Colin Alworth
18 Oct 2011, 12:35 PM
This error indicates that the GXT jar you are using is built for a different version of GWT. When downloading the zip from the sencha site, make sure to select the jar with the version that matches the GWT version you are using.

apandey1
21 Oct 2011, 4:33 AM
Thanks for reply.

I copied XMessages.properties present inside the GXT jar to our workspace where we had overridden it.
Seems this key was missing:
listField_itemsSelected='{0'}itemsselected

in XMessages files which we had e in our workspace. After copy property file the error went away and we were able to compile the application.

We are planning to upgrade our GWT 2.0.4 to latest release. I wanted to know if GXT jar: gxt-2.2.5-gwt22.jar which comes with GXT 2.2.5 distribution supports latest GWT 2.4.0 or is it for GWT 2.2.0.

sven
21 Oct 2011, 4:59 AM
the gwt22.jar file supports GWT 2.2 and upwards. This includes GWT 2.4

shingocat
24 Nov 2011, 6:29 PM
So I thought it is very important to have list about the GXT there jar for which GWT.

Cypher
2 Dec 2011, 7:24 AM
There is an incorrect version number in the title for Release 2.2.5 in Release Notes (http://dev.sencha.com/deploy/gxt-2.2.5/release_notes.html) - the title reads "Release 2.2.4 (Released September 15th, 2011)" instead of correct "Release 2.2.5 (Released September 15th, 2011)".