PDA

View Full Version : Failed on Deploying ExtGWT-Spring project on Eclipse



ganda
6 Nov 2011, 11:29 PM
Hi all.

I'm developing your application using UI technologies Ext-GWT version 2.x and Spring Framework. Previously I imported an existing project, and then make some changes in the interface. After I did the "Run on Server" using Eclipse Indigo, it turns out the changes that I did, is not happening. Interface remains as usual. I try to print something on the Main panel, also did not display anything on the console, while if I do print something on the back-end that using Spring Framework (still on the same eclipse project), something is printed in the console.

Is there anyone ever experienced the same problem? How is the solution to this problem?
I've tried deleting all the files in the build folder, to be "forced" to get a compilation of new classes, it did not solve the problem.

Any suggestion, clue, will be appreciated. :) Thanks in advance.

ganda
7 Nov 2011, 12:15 AM
Hi all.

I'm developing your application using UI technologies Ext-GWT version 2.x and Spring Framework. Previously I imported an existing project, and then make some changes in the interface. After I did the "Run on Server" using Eclipse Indigo, it turns out the changes that I did, is not happening. Interface remains as usual. I try to print something on the Main panel, also did not display anything on the console, while if I do print something on the back-end that using Spring Framework (still on the same eclipse project), something is printed in the console.

Is there anyone ever experienced the same problem? How is the solution to this problem?
I've tried deleting all the files in the build folder, to be "forced" to get a compilation of new classes, it did not solve the problem.

Any suggestion, clue, will be appreciated. :) Thanks in advance.

I mean an application...

Colin Alworth
7 Nov 2011, 6:28 AM
GWT code is compiled not just to .class files, but to javascript, which should be served by your webserver to the browser. Any logging calls written in client code won't automatically be printed to the server's console, as they are running on the web browser in javascript, not on the server.

If using maven or ant, there should be a goal/target in your build stuff that runs the compile. If just using the eclipse plugin, make sure to click the GWT Compile button. Beyond that, you'll need to make sure your page correctly loads the js files.

ganda
8 Nov 2011, 6:27 PM
Hi Colin,

Thanks for your answer. It solved. Like you replied, I tried to GWT compile the source code its working awesomely now. :D