PDA

View Full Version : namespace is undefined EXTJS4



utkarshk.leeway
23 Nov 2011, 12:25 AM
Hi,

i am facing problem "namespace is undefined" after uploading my working application from localhost to hostgator account. The complete application is working fine on my localhost however once uploded to proper hosting server, it is failing to load. I have uploaded all necessary files to be uploaded for EXTJS. my extjs version is 4. Please Help

Regards
UT

flanders
23 Nov 2011, 3:13 AM
This is way to little information to even start helping you. Best guess would be that one of the javascript files is not getting loaded, but really an guess

Since you say it is online, maybe you can post the url? If the code isn't minified yet, people can take a look

utkarshk.leeway
23 Nov 2011, 3:44 AM
hi,

thanks for your quick reply, here are the credentials for the application.

http://www.leeweb20.com/appsystem/login.php
username: admin@leewayhertz.com
password:1234

you can check it here.

I have updated the latest working code from the local repo. Please see and suggest that what is missing.

Thanks in advance.
Regards
UT

utkarshk.leeway
23 Nov 2011, 3:57 AM
an update- i tried removing ext-debug-all.js and replacing with ext-all.js now it says "g is undefined"

redraid
23 Nov 2011, 4:22 AM
xtype: 'ComboBox' This widget not defined in you app.

utkarshk.leeway
23 Nov 2011, 4:49 AM
hi redraid,

thanks for the reply, can you please tell me which .js file i have missed to define the xtype if you have found any particular js file

THanks

utkarshk.leeway
23 Nov 2011, 5:15 AM
Thanks a zillion redraid, it just worked. please tell me how u did debug it. that will be really great help.