PDA

View Full Version : Error installing sass:invalid gem format for C:/Ruby193....



JDev_Job
25 Nov 2011, 8:02 AM
Hi, help me please...


C:\Ruby193\bin>gem install compass --version=0.11.1

Fetching: sass-3.1.10.gem (100%)
Fetching: compass-0.11.1.gem (100%)
Successfully installed sass-3.1.10
Successfully installed compass-0.11.1
2 gems installed
Installing ri documentation for sass-3.1.10...
Installing ri documentation for compass-0.11.1...
Installing RDoc documentation for sass-3.1.10...
Installing RDoc documentation for compass-0.11.1...


C:\Ruby193\bin>compass -v

Compass 0.11.1 (Antares)
Copyright (c) 2008-2011 Chris Eppstein
Released under the MIT License.
Compass is charityware.
Please make a tax deductable donation for a worthy cause: http://umdf.org/compass

C:\Ruby193\bin>sass -v

Sass 3.1.10 (Brainy Betty)


C:\Ruby193\bin>gem uninstall sass

You have requested to uninstall the gem:
sass-3.1.10
compass-0.11.1 depends on [sass (~> 3.1)]
If you remove this gems, one or more dependencies will not be met.
Continue with Uninstall? [Yn] y
Remove executables:
sass, sass-convert, scss

in addition to the gem? [Yn] y
Removing sass
Removing sass-convert
Removing scss
Successfully uninstalled sass-3.1.10


C:\Ruby193\bin>gem install sass --version=3.1.1

ERROR: Error installing sass:
invalid gem format for C:/Ruby193/lib/ruby/gems/1.9.1/cache/sass-3.1.1.gem





C:\Ruby193\bin>ruby -v
ruby 1.9.3p0 (2011-10-30) [i386-mingw32]

Thanks!

mitchellsimoens
25 Nov 2011, 8:07 AM
Why did you uninstall SASS?

JDev_Job
25 Nov 2011, 8:12 AM
http://www.sencha.com/forum/showthread.php?130517-Help-with-ExtJS-4-Theme/page2

JDev_Job
25 Nov 2011, 8:25 AM
C:\Ruby193\bin>gem install compass --version=0.11.1


......\resources\sass>compass compile
error my-ext-theme.scss (Line 115: Functions may only be defined at the root of a document.)
identical ../css/my-ext-theme.css

JDev_Job
25 Nov 2011, 8:38 AM
http://www.sencha.com/forum/showthread.php?149266-Theming-issue-Line-15-Functions-may-only-be-defined...

Same problem
I have Sass 3.1.10 and compass 0.11.1 and I'm still getting the error: Functions may only be defined at the root of a document.

I'm new to using sass/compass and I'm not sure If I have my folders set up right. I only have access to the resource directory and I am trying the following:
sass --watch /resources/sass

That could be my problem but I just don't know.