PDA

View Full Version : [CLOSED] [PR1] Setting disableCaching: false doesn´t remove "_dc" parameter



SunboX
26 Nov 2011, 10:21 AM
I´ve enabled caching by setting:


Ext.Loader.setConfig({ enabled: true,
disableCaching: false,
paths: {
'App': 'app'
}
});

But the "_dc" parameter is still appended to all JavaScript files. Like the AppControler.js:


http://sunbox.github.com/Fotoideen/app/controller/AppController.js?_dc=1322331503522

I think this is a bug?

greetings Sunny

aguerra10
27 Nov 2011, 12:18 PM
I´ve enabled caching by setting:


Ext.Loader.setConfig({ enabled: true,
disableCaching: false,
paths: {
'App': 'app'
}
});

But the "_dc" parameter is still appended to all JavaScript files. Like the AppControler.js:


http://sunbox.github.com/Fotoideen/app/controller/AppController.js?_dc=1322331503522

I think this is a bug?

greetings Sunny

I may be wrong, but as I understand it, if you want _dc to disappear you have to disableCaching.. So the setting should be "disableCaching: true" not false.. As I said before, I may be wrong but you should try that..

SunboX
27 Nov 2011, 12:30 PM
No, that´s wrong. "_dc" is disabling the cache. ;o) That means, if disableCaching is enabled, "_dc" will be appended to every request, so the browsers does reload the filed. (and doesn´t load it from cache)

greetings Sunny

aguerra10
27 Nov 2011, 12:58 PM
You are right mate!! I've just tried it in PR2 (disableCaching: false) and the _dc has goneee!!