PDA

View Full Version : Question re: Upgrading to Ext JS 4.x



rmorales
7 Dec 2011, 12:48 PM
I am really worried, I have been using Ext 3.2, I have a new proyect and I dont know if use Ext 4.0, because I dont see documentation about this.

The new proyect is big. WHAT SHOULD I DO????

tobiu
7 Dec 2011, 1:09 PM
you definitely should upgrade your old project to 3.4.

if you take a close look at the menu on top of this page, there is a link documentation which allows you to see the docs for (almost) all sencha products.

use the guides to get into the new goodies:
http://docs.sencha.com/ext-js/4-0/#!/guide

tvanzoelen
8 Dec 2011, 12:31 AM
My suggestion, wait until 4.1 comes out. Meanwhile you can start learning the new framework.

4.07 is for most users still not suitable for production, unless you build small sized applications.

hannas
7 Feb 2012, 9:30 AM
My existing code is written in Ext-JS 2.2. Should I upgrade to 3.4 first then upgrade to 4.x?

skirtle
9 Feb 2012, 10:09 AM
Personally I wouldn't go 2 to 3 to 4. Either jump straight to 4 or do a rewrite. It takes someone with a good understanding of your app to assess which approach will be faster. Either way, make sure you spend some time learning Ext 4 before you start the switch. Writing a small practice app is a good way to learn and allows you to make your mistakes on a smaller scale before you write the code that matters.