PDA

View Full Version : theming is still broken



albeva
19 Jan 2012, 6:46 AM
I've followed the steps in the documentation and this is what I get (4.0.7)

Alberts-Mac-mini:sass albeva$ compass compile
error ext-all-access.scss (Line 115: Functions may only be defined at the root of a document.)
overwrite ../css/ext-all-access.css
error ext-all-gray.scss (Line 115: Functions may only be defined at the root of a document.)
overwrite ../css/ext-all-gray.css
error ext-all-scoped.scss (Line 115: Functions may only be defined at the root of a document.)
overwrite ../css/ext-all-scoped.css
error ext-all.scss (Line 115: Functions may only be defined at the root of a document.)
overwrite ../css/ext-all.css
error ext-ie-scoped.scss (Line 115: Functions may only be defined at the root of a document.)
overwrite ../css/ext-ie-scoped.css
error ext-ie.scss (Line 115: Functions may only be defined at the root of a document.)
overwrite ../css/ext-ie.css
DEPRECATION WARNING:
On line 848 of "/Users/albeva/Sites/ext-4.1.0-beta-1/resources/themes/stylesheets/neptune/default/widgets/_grid.scss", after " &"
Starting in Sass 3.2, "-ml" may only be used at the beginning of a selector.

DEPRECATION WARNING:
On line 848 of "/Users/albeva/Sites/ext-4.1.0-beta-1/resources/themes/stylesheets/neptune/default/widgets/_grid.scss", after " &-ml, &"
Starting in Sass 3.2, "-mr" may only be used at the beginning of a selector.

DEPRECATION WARNING:
On line 848 of "/Users/albeva/Sites/ext-4.1.0-beta-1/resources/themes/stylesheets/neptune/default/widgets/_grid.scss", after "... &-ml, &-mr, &"
Starting in Sass 3.2, "-bl" may only be used at the beginning of a selector.

DEPRECATION WARNING:
On line 848 of "/Users/albeva/Sites/ext-4.1.0-beta-1/resources/themes/stylesheets/neptune/default/widgets/_grid.scss", after "..., &-mr, &-bl, &"
Starting in Sass 3.2, "-br" may only be used at the beginning of a selector.

DEPRECATION WARNING:
On line 848 of "/Users/albeva/Sites/ext-4.1.0-beta-1/resources/themes/stylesheets/neptune/default/widgets/_grid.scss", after "..., &-bl, &-br, &"
Starting in Sass 3.2, "-bc" may only be used at the beginning of a selector.

DEPRECATION WARNING:
On line 853 of "/Users/albeva/Sites/ext-4.1.0-beta-1/resources/themes/stylesheets/neptune/default/widgets/_grid.scss", after " &"
Starting in Sass 3.2, "-bl" may only be used at the beginning of a selector.

DEPRECATION WARNING:
On line 853 of "/Users/albeva/Sites/ext-4.1.0-beta-1/resources/themes/stylesheets/neptune/default/widgets/_grid.scss", after " &-bl, &"
Starting in Sass 3.2, "-br" may only be used at the beginning of a selector.

DEPRECATION WARNING:
On line 859 of "/Users/albeva/Sites/ext-4.1.0-beta-1/resources/themes/stylesheets/neptune/default/widgets/_grid.scss", after " &"
Starting in Sass 3.2, "-bl" may only be used at the beginning of a selector.

DEPRECATION WARNING:
On line 863 of "/Users/albeva/Sites/ext-4.1.0-beta-1/resources/themes/stylesheets/neptune/default/widgets/_grid.scss", after " &"
Starting in Sass 3.2, "-br" may only be used at the beginning of a selector.

DEPRECATION WARNING:
On line 867 of "/Users/albeva/Sites/ext-4.1.0-beta-1/resources/themes/stylesheets/neptune/default/widgets/_grid.scss", after " &"
Starting in Sass 3.2, "-bc" may only be used at the beginning of a selector.

DEPRECATION WARNING:
On line 875 of "/Users/albeva/Sites/ext-4.1.0-beta-1/resources/themes/stylesheets/neptune/default/widgets/_grid.scss", after " &"
Starting in Sass 3.2, "-ml" may only be used at the beginning of a selector.

DEPRECATION WARNING:
On line 875 of "/Users/albeva/Sites/ext-4.1.0-beta-1/resources/themes/stylesheets/neptune/default/widgets/_grid.scss", after " &-ml, &"
Starting in Sass 3.2, "-mr" may only be used at the beginning of a selector.

DEPRECATION WARNING:
On line 881 of "/Users/albeva/Sites/ext-4.1.0-beta-1/resources/themes/stylesheets/neptune/default/widgets/_grid.scss", after " &"
Starting in Sass 3.2, "-ml" may only be used at the beginning of a selector.

DEPRECATION WARNING:
On line 884 of "/Users/albeva/Sites/ext-4.1.0-beta-1/resources/themes/stylesheets/neptune/default/widgets/_grid.scss", after " &"
Starting in Sass 3.2, "-mr" may only be used at the beginning of a selector.

overwrite ../css/ext-neptune.css
error ext-sandbox.scss (Line 115: Functions may only be defined at the root of a document.)
overwrite ../css/ext-sandbox.css
error ext-standard-scoped.scss (Line 115: Functions may only be defined at the root of a document.)
overwrite ../css/ext-standard-scoped.css
error ext-standard.scss (Line 115: Functions may only be defined at the root of a document.)
overwrite ../css/ext-standard.css

burnnat
19 Jan 2012, 7:11 AM
I have a ticket open for this issue here (http://www.sencha.com/forum/showthread.php?158358-4.0.7-Syntax-errors-when-compiling-SASS-themes) (EXTJSIV-4602). Also, in that thread, mystix (http://www.sencha.com/forum/member.php?1459-mystix) provided a diff patch you can apply to your copy of extjs that will fix the compilation errors.