PDA

View Full Version : Ext JS theming for IE & Opera



rodrigorum
19 Jan 2012, 11:27 AM
Hi,

I'm pretty new using EXT JS and I just can't find how to change the widgets header colors (panel header).

See, I downloaded compass and ruby and modified the .scss file. It worked perfectly in FF and Chrome. However, It didn't work for ie and opera 11. I've tried to change the .css (x-panel-header... and similar selectors), but all my attempts have been unfruitful as of ie and opera.

[Also, when I run compass compile, I get a lot of warnings on the screen:
WARNING: @theme-background-image: Theme image not found: ../../resources/themes/images/tt/tools/tool-sprites.gif
on line 18 of C:/ext js/extJS407-2/ext-4.0.7-gpl/resources/themes/stylesheets/ext4/default/mixins/_theme-background-image.scss, in `extjs-tool
from line 108 of C:/ext js/extJS407-2/ext-4.0.7-gpl/resources/themes/stylesheets/ext4/default/_all.scss
from line 118 of C:/ext js/extJS407-2/ext-4.0.7-gpl/resources/sass/b.scss
ut anyway the css is generated and works correctly in chrome and ff).]

[I already tried the theme generator for 3.0.0 hoping it worked with 4,but it didn't]

mitchellsimoens
19 Jan 2012, 12:24 PM
The path to your image was not found.

rodrigorum
19 Jan 2012, 12:45 PM
Ok, this was a waste of space. I kept looking and found that the slice tool was what I needed.


sencha slice theme -d C:\ext-4.0.7-gpl -c ./css/themeX.css -o ./themes/images/themeX

ran from the resources folder.

phoenix06
30 Jan 2012, 9:21 AM
Hello, I have a problem when slicing:

Due to our own architecture of software, I have not exactly the same folder arrangement as wanted by sencha. I type this :


c:\wamp\www\lib>sencha slice theme --ext-dir ./extJs --css ./resources/css/mys-ext-theme.css --output-dir ./resources/images -verbose

And it says me that



C:\Program Files\SenchaSDKTools-1.2.3\command\\src\CliOptions.js:127 TypeError: this.get is not a function
Execution error in C:\Program Files\SenchaSDKTools-1.2.3\command\sencha.js.


I uninstall and re-install sdktools but no changes.
Any idea?

Thanks a lot

nota: when I try to use short words as -c -v -d -o ... it shows me the help!

phoenix06
30 Jan 2012, 9:55 AM
Sorry I found,
I misstyped the name of my css file.

That doesn't solve the problem of that IE work bad with ExtJs theming but I can start work on it.