PDA

View Full Version : stop adding class="x-border-box" to html tag



ekitel
20 Jan 2012, 9:40 AM
EXT JS is adding class="x-border-box" to the HTML tag of our page after it is served. We do need that class in order to render the our EXT JS based scheduler correctly, however it is causing problems with other elements on our page. I think we would like to manually add class="x-border-box" to the element that contains the scheduler widget and stop EXT JS from adding it automatically to the HTML.

Hopefully this is an easy issue to resolve and should be relevant to anybody who is trying to embed EXT JS functionality within a standard web page.

mitchellsimoens
20 Jan 2012, 11:46 AM
You can add CSS to the components you don't want it to and override the rules x-border-box brings.

ekitel
20 Jan 2012, 12:11 PM
this is a huge site, we only use EXT JS on a couple pages, we're not about to overhaul all our CSS to accommodate EXT JS... why can't it just target what we need and leave everything else alone?

JoelB
14 May 2012, 6:29 AM
I ran into the exact same issue. Please by all the patterns we hold dear, dont add global classes or polute the global namespace.

And specially with propeties without a settable default such as inherited.

Is it possible to stop ext from setting this property?

Please help!

//J

dawesi
27 Nov 2013, 6:28 PM
+1