PDA

View Full Version : ItemSelector rendering problem in 4.1 Beta



Atari400
23 Jan 2012, 5:31 PM
The ItemSelector example that came with the 4.1 Beta downlowd shows a blank widget when I deployed. Code is in /examples/multiselect/multiselect-demo.html, multiselect-demo.js. I see a blank panel for the ItemSelector. Can someone confirm if this is indeed a problem?


/*
* Ext.ux.form.ItemSelector Example Code
*/
var isForm = Ext.widget('form', {
title: 'ItemSelector Test',
width: 700,
bodyPadding: 10,
height: 300,
renderTo: 'itemselector',
layout: 'fit',
items:[{
xtype: 'itemselector',
name: 'itemselector',
id: 'itemselector-field',
anchor: '100%',
fieldLabel: 'ItemSelector',
imagePath: '../ux/images/',
store: ds,
displayField: 'text',
valueField: 'value',
value: ['3', '4', '6'],
allowBlank: false,
msgTarget: 'side'
}],
dockedItems: createDockedItems('itemselector-field')
});

mitchellsimoens
24 Jan 2012, 10:52 AM
If you run it off of the file system then yes it won't work but running it off of a web server works just fine.

Atari400
30 Jan 2012, 2:07 PM
I ran it from a web server and it is still blank.

Atari400
30 Jan 2012, 2:25 PM
I just downloaded 4.1 Beta2, it shows up now.

wemerson.januario
20 Feb 2012, 5:34 PM
can not run it inside Ext.window.Window().

delusion
14 Mar 2012, 12:43 PM
I have the same issue, just a blank area.

I had a similar problem in 4.0.7 but i was able to get around it by creating the widget during the load event of the store.

iomanip
18 Mar 2012, 7:42 AM
Make sure the Itemselector Element hast it's own height and width property. That should do it for the beta.