PDA

View Full Version : After Build, files are still loaded on demand from ext.js



fabio.policeno
24 Jan 2012, 4:11 AM
Good morning gentlemen,

Done after the deploy of my application was correctly generated app-all.js. I call him and the ext.js on my page (Ext JS 4.0.7 with Windows 7):

<head>
<link rel="stylesheet" type="text/css" href="extjs/resources/css/ext-all-gray.css" />
<script type="text/javascript" src="extjs/ext.js"></script>
<script type="text/javascript" src="extjs/locale/ext-lang-pt_BR.js"></script>

<script type="text/javascript" src="app-all.js"></script>
</head>

But in the firebug console still see the files being loaded on demand (image attached), but now at ext.js.
How do I load it only ext.js and app-all.js? Any suggestions?

Below is my app.js (I require for all tests, but still did not work correctly):


Ext.Loader.setConfig({
enabled: true,
paths : {
'Sinasempu' : 'app',
'Ext' : 'extjs/src',
'Helper' : 'app/helper',
'Abstracts' : 'app/abstracts',
'Ext.ux' : 'app/ux',
'Ext.ux.desktop': 'app/ux/desktop/src'
}
});

Ext.require([
'Sinasempu.*',
'Ext.*',
'Helper.*',
'Abstracts.*',
'Sinasempu.*'
]);

Ext.application({
name: 'Sinasempu',

launch: function() {
App = this;
App.getController('Autenticacao').init();
}
});

Thank you!
30944

chramer
24 Jan 2012, 5:06 AM
try to clear the cache!

fabio.policeno
24 Jan 2012, 8:46 AM
got it!
now I have another problem
My controllers are strange
on the login screen
I enter the User
She says the field is empty
will be a problem in the core ext?
was the problem in deploy:
have to run the app with the ext-all-dev
to see all warnings
of files that need to be included and are not being included
then includes all the app.js
also another problem that was occurring
is that the files jsb3
were being generated elsewhere
I was running the wrong way
now
encoding
was wrong after deployment
it changes the browser to ISO
automatic.
the order of the controllers is?
controllers: [
'Authentication',
'Login'
'Main'
'Affiliated'
'User',
'Election',
'EleicaoCandidato'
'EleicaoChapa'
'Area'
]
a controller that does this Login

fabio.policeno
26 Jan 2012, 5:38 PM
I just notice the following:
Including these my controllers, this coding error occurs and you can not recover the value of the field user.
If I remove the Login controller, works perfectly:
controllers: [
'Authentication',
/ / 'Login'
'Main'
'Affiliated'
'User',
'Election',
'EleicaoCandidato'
'EleicaoChapa'
'Area'
]

What should be the problem?

Thank you!

fabio.policeno
28 Jan 2012, 4:13 AM
Resolved.

The problem really is in the coding, the app generates sdk-all with ANSI encoding. How do I set it to UTF-8?

Thank you!