PDA

View Full Version : [FIXED] Unable to establish internet connection to begin software registration.



daubman
30 Jan 2012, 5:19 PM
I just downloaded the open beta of Sencha Designer 2. After agreeing to the license agreement I get the error page:
"""
Unable to establish internet connection to begin software registration.
Please check your internet connection and retry or manually configure a proxy.

"""

I'm currently on home WiFi with no proxy, and my Ext Designer 1.2 loads up just fine...

...suggestions (current browser is obviously working to reach the forums and no proxy configured here or in Network Preferences - Mac OS X 10.7.2)

Very excited to _finally_ try the Designer2 Beta - now just wishing I could launch it! :((

Thanks,
Aaron

aconran
30 Jan 2012, 5:22 PM
Aaron -

Could you give us some more details about your environment? Operating system, etc

daubman
30 Jan 2012, 5:27 PM
Mac OS X 10.7.2 (Lion) running on a MacBook Pro.

I double-checked my Network Location to ensure I'm on the home location with no proxy config. All browsers (and licensed Designer 1.2) are working fine.

I also tried the manual proxy config option leaving all the proxy config fields blank and received the same error message.

daubman
30 Jan 2012, 5:30 PM
These three lines are all that are logged in when launching the app:


1/30/12 8:29:02.289 PM [0x0-0x232232].com.sencha.SenchaDesigner: Loading libion: /Users/aaron/Library/Application Support/Sencha, Inc./Sencha Designer 2.0/libion-1.3.8.dylib
1/30/12 8:29:02.838 PM [0x0-0x232232].com.sencha.SenchaDesigner: Loading Ion resource: /Users/aaron/Library/Application Support/Sencha, Inc./Sencha Designer 2.0/xds-2.0.0.000268.ion
1/30/12 8:29:02.909 PM [0x0-0x232232].com.sencha.SenchaDesigner: Load result: Success

Phil.Strong
1 Feb 2012, 7:27 PM
we were having issues with our servers. Can you try this again to be sure it wasn't an issue as simple as this.

daubman
2 Feb 2012, 4:52 AM
I'll try it again tonight when I'm back on home WiFi and will report the results. It sounds like that may be it, since the next day I loaded it up on my work machine, complete with proxy config, and everything worked fine...

Thanks,
Aaron

jarrednicholls
2 Feb 2012, 3:08 PM
We are in the process of resolving this issue - it turns out to be a server infrastructure issue on a few of our provisioned nodes. We will ping this thread once again when the issue is fully resolved. Thanks.

jarrednicholls
2 Feb 2012, 3:13 PM
Apologies, this issue is not (seemingly?) directly related to the problem we've been experiencing on our servers - I read the thread too fast. But, do try again later tonight just in case our solution to one problem happens to resolve your problem as well. Thanks.

KimH
2 Feb 2012, 3:30 PM
I'm having problems logging in using the Sencha Designer 2 beta.

Using my Sencha ID and password I get an "A communication error has occurred." at the login screen.

No problem logging in using a browser to the forums.

No special proxy, Ubuntu 10.10

jarrednicholls
2 Feb 2012, 3:32 PM
Hi KimH,

Your issue is directly related to our server problems I mentioned two posts up (http://www.sencha.com/forum/showthread.php?177700-Unable-to-establish-internet-connection-to-begin-software-registration.&p=726061&viewfull=1#post726061). This can be "worked around" by closing your application and retrying over and over again, and "one time" it should work. However, you can wait until later today when we have the issue resolved; I will ping this thread at that time.

Cheers,
Jarred

aconran
2 Feb 2012, 4:04 PM
2 of the 5 servers running the licensing checks are failing. They will be updated tomorrow.

daubman
3 Feb 2012, 3:48 PM
An Update: I am still receiving this error on my home MB Pro running OS X 10.7.2 - not behind any proxy, although I am behind the typical home NAT gateway.

When running from work on a different mac (also running 10.7.2) from behind a corporate proxy the beta1 loaded fine...

The older Ext Designer xds-1.0.2.14 continues to load fine on both computers.

Thanks again,
Aaron

aconran
3 Feb 2012, 4:18 PM
Aaron - Still waiting for our ops guys to be willing to reboot the servers. Hopefully this resolves your issue.

aconran
3 Feb 2012, 7:24 PM
Please try again. I believe this issue is resolved.

aladon84
5 Feb 2012, 4:43 AM
Hello,

For me, sencha designer 2 still return "A communication error has occurred." during the login.
I'm on ubuntu 10.04 64bits.

Thanks

daubman
5 Feb 2012, 2:08 PM
I am still receiving the same message as of 2/5/2012 @ 17:00:
31375

aconran
6 Feb 2012, 12:50 PM
Aaron please email designer.feedback at sencha.com so that we can work with you individually and get this up and running. :-/

gdd
6 Feb 2012, 2:51 PM
FYI

I'm also getting "A communication error has occurred."

System: Kubuntu 10.04
KDE: 4.4.5

Regards
Grant

Phil.Strong
10 Feb 2012, 11:33 AM
we've updated our installers for Linux which will fix some of the issues for registration. Get the new installers here http://www.sencha.com/forum/showthread.php?152941-Sencha-Designer-2-Beta-Download-links&p=666386#post666386

firehawkdc
15 Feb 2012, 5:31 PM
I'm having the same issue (A communication error has occurred).
No proxy. Running on Windows Vista.
Tried running with and without Firewall/Antivirus.

Any advice?

Zavel
19 Feb 2012, 4:22 PM
Hi, i'm receiving this error: i have provided a manual proxy configuration but that failed. I also tried connecting to a wireless network where there is no proxy server, and attempted to register sencha designer 2 that way but it also isn't working.

Please let me know your thoughts. Are your servers available?

Thanks,
Ryan.

aconran
20 Feb 2012, 8:14 AM
Please let me know your thoughts. Are your servers available?


Yes, please let us know additional details on the other thread you opened.