PDA

View Full Version : [FIXED] Linux Code Editor Cursor does not match where you are typing



tfd
31 Jan 2012, 12:16 AM
Just been testing Designer 2. Brilliant ideas! You guys were probably high on ~o) the past few months!

One minor bug:
in the code editor, when typing new lines, the cursor seems to run away from the code after a few characters. eg add a tool click event and in the code of the event, try typing in: alert('hello world');
After typing the l the cursor is one character further to the right than where you are typing. By the time you get to the first ' it is about 5 characters to the right of the text, making editing code very, uhm, difficult, tricky, challenging, lets settle on fun, but with limited patience :((

One major bug:
Create a new 4.0 project. Add a viewport containing a panel containing a label. Leave everything as default. Saving and exporting results in nothing being displayed and nothing picked up by firebug. The project defaults to 4.0.2a, but the same results seem to happen for 4.0.7. Not sure if its related, but no designer_includeOrder.txt gets deployed and creating it manually does not resolve the issue.

tfd
31 Jan 2012, 6:26 AM
It turns out that export on Linux, does not add this line to designer.js:

autoCreateViewport: true,

Once added, project displays fine.

aconran
31 Jan 2012, 8:15 AM
the cursor seems to run away from the code after a few characters

Could you give us a screenshot? This was happening on windows before we made sure that the system was using the proper font within the code editor. I'm guessing that none of the fixed width fonts we are using are installed on your system.




One major bug:
Create a new 4.0 project. Add a viewport containing a panel containing a label. Leave everything as default. Saving and exporting results in nothing being displayed and nothing picked up by firebug. The project defaults to 4.0.2a, but the same results seem to happen for 4.0.7.
Are you deploying this to a webserver and loading it over http?



Not sure if its related, but no designer_includeOrder.txt gets deployed and creating it manually does not resolve the issue.
This is just coincidence and does not cause the project to work.

aconran
31 Jan 2012, 8:15 AM
It turns out that export on Linux, does not add this line to designer.js:

autoCreateViewport: true,

Once added, project displays fine.

Could you send us the project? Is this option enabled on Application? Do you have a view marked as the initial view?

tfd
31 Jan 2012, 9:50 PM
I've attached a zip file containing 2 screenshots and a test project.

Screenshot 1 shows the cursor issue and the other show the test project with the view indicated as initial view.

The sample project has basically no code. Its just a label on a panel on a viewport. I deploy it to my apache installation on my local machine. Deploying to a shared webhost give the same results.

I use Designer 2.0.0 Build 268 64 bit on Ubuntu 11.10. I have the default Ubuntu fonts installed as well as the fonts from the MS Core fonts package which includes Windows fonts such as Courier New.

Hope this helps.31216

aconran
31 Jan 2012, 9:55 PM
I think (hope) that the screenshot in the zip file named Screenshot at 2012-02-01 07/27/58.png has been corrupted. It has a bunch of scrambled lines and bright colors.

aconran
31 Jan 2012, 9:57 PM
The sample project has basically no code. Its just a label on a panel on a viewport. I deploy it to my apache installation on my local machine. Deploying to a shared webhost give the same results.


Click on Application in the top right hand side of the inspector. Check the autoCreateViewport option in the bottom right hand side of the grid. Save the project and it should start working.

tfd
31 Jan 2012, 10:06 PM
Thanks, feel a bit silly now, not noticing that.

I've attached the screenshot of the cursor.
31217

aconran
31 Jan 2012, 10:25 PM
Thanks, we'll see if we can make an environment where we can reproduce the issue.

tfd
31 Jan 2012, 10:37 PM
Thanks.

Just for my reference, which font do you use on Windows to resolve the issue?

I can install that in the mean time and let you know if using the same font on Linux resolves it.

aconran
31 Jan 2012, 10:45 PM
On Windows the preference is Courier. Taking a look at the source code, this is not going to automatically fix itself in linux by installing this font. We will look into it further.

Thanks.

Phil.Strong
1 Feb 2012, 5:37 PM
how wide is your resolution. Does the issue go away when you make this smaller?

tfd
1 Feb 2012, 10:31 PM
It looks like the cursor issue is not linked to resolution. I use 2 monitors with the same effect regardless of on which the designer is used and regardless of whether the program is in a maximized or restored window.

The resolutions I use is 1) 1920x1080 and 2)1280x1024

jarrednicholls
2 Feb 2012, 3:09 PM
We have resolved this issue for our next update release. Thanks for the report!