PDA

View Full Version : [FIXED] Store Load Failure - What changed?



Artistan
31 Jan 2012, 5:14 AM
Right Click on store - Load Store

An unexpected error occurred.
TypeError: 'undefined' is not an object

Attached a copy of the example project (uber-small)

Window 7 64bit
Designer build 268 (updated after fresh install, still error)


Updated zip with Model fields and Reader.
Still having error with Load Store!

Artistan
31 Jan 2012, 5:19 AM
I tried adding some fields to the Model, no luck, same error.

Artistan
31 Jan 2012, 5:24 AM
Ok, looks like the userclassname of "Visits" is not being used in the application model config which shows 'MyModel'

Artistan
31 Jan 2012, 5:26 AM
Ok, looks like the userclassname of "Visits" is not being used in the application model config which shows 'MyModel'

This must be a new "automatic" thing for adding models.

Artistan
31 Jan 2012, 5:27 AM
added a List to this project.
Clicked on the store config for the list
ERROR
TypeError: 'null' is not an object

Artistan
31 Jan 2012, 5:29 AM
added a List to this project.
Clicked on the store config for the list
ERROR
TypeError: 'null' is not an object



Restarted designer, added panel then a list to the panel and then the store added without error.

Artistan
31 Jan 2012, 5:32 AM
Changing class name on a View does not update the Application views config either.
This could cause a lot of unexpected errors.

Artistan
31 Jan 2012, 5:57 AM
Changing class name on a View does not update the Application views config either.
This could cause a lot of unexpected errors.

changes store config in application when store classname changes, but not for Model and View.

dfoelber
2 Feb 2012, 2:29 PM
Hi,

Thanks for the help!

This issue is fixed and will be included in the next autoupdate.