PDA

View Full Version : Setting GroupingView to grid increases update time of grid to some degree



Evgeny Fisher
9 Feb 2012, 1:01 AM
Hi .
I have instance of Grid with 50 rows and 7 columns.
On pressing button all rows of grid are updating by following calling: gridStore.update( testGridNode );
For grid without grouping view update takes about 0.6 second.
Update of Grouping Grid takes about 3.4 seconds!
Simple test case is attached.
The questions are:
Is there way to improve it?
May be is there way of multiple update, like multiple add ( method that receives list of models )?
Is something planned for next release for improving this bad update performance?
We are using Ext GWT 2.2.4.

Thank you,
Evgeny

Colin Alworth
14 Feb 2012, 9:26 AM
What are you trying to do by calling update in a loop like that? On update, the grouping grid must decide if changes to any grouping has occurred - not something that can be simply done.

If you want to replace all of the items, then do that (call removeAll() then add the data back in again). Another option would be to disable the grouping while performing all of those updates.

As far as I can tell, updateRows() and gridStore.commitChanges() are not serving any purpose in your code, as there are no changes to commit, and no updates to inform the grid of.

If you can describe your usecase with some more detail, that might be helpful to get a more meaningful answer.

Evgeny Fisher
15 Feb 2012, 12:39 AM
Hi Collin.
Thank you for your response.
Still I think grouping grid view is useful view and hope is popular enough so it should have better update performance.
Our real case is following: we have grouping grid with 100-150 rows, 7 columns, about 1-5 groups, one or more properties of row model are changed in about 70% of all rows each 1-2 seconds. Removing and adding all rows again is not suitable for us. But probably we can try to disable grouping while performing updates. Can you please advise how to do it?

Thank you,
Evgeny

Evgeny Fisher
4 Mar 2012, 4:23 AM
Hi Colin
Can you please advise how to disable the grouping while performing all rows updates?

Thank you,
Evgeny