PDA

View Full Version : [FIXED] .metadata + svn = fail



hotdp
24 Feb 2012, 12:43 AM
Hi,
I am using Designer 2 for a large application for a big company. So it is importend for us that it is in svn so no work gets lost.

But we are having big problems with .metadata:
32104
When I add the solution the first time there is no problem. But the first time I save in the Designer something happens to the .metadata folder (I think files are deleted (also svn files?)). I know that the folder contains importent files for the project and therefor I would like to have them in svn to.

I have tried adding/removing and many things but the problem will always occur when I save.

bharatn
24 Feb 2012, 12:52 AM
Can you explain this more - "but the problem will always occur when I save."

Are you saying that every time you save, the metadata gets deleted?

hotdp
24 Feb 2012, 12:56 AM
Can you explain this more - "but the problem will always occur when I save."

What I am trying to say is that if it is a new project just added to svn, there is no problem. But the first time a pres save inside the designer there will be problems with the .metadata folder in SVN and I can't commit the changes to .metadata.


Are you saying that every time you save, the metadata gets deleted?

No the .metadata folder is not deleted but by reading the error message from SVN I suspect the designer to delete the SVN files in the folder and thats why it can't commit?

Phil.Strong
24 Feb 2012, 1:07 AM
*sheepish*
Apologies we've yet to test with SVN as we are set in our ways here using Git ... shame on us.

Yes at the moment we are wipe everything in the directory (.metadata) and rewriting the metadata.

Fix coming soon will only wipe out files designer knows about

bharatn
24 Feb 2012, 1:10 AM
This definitely looks like a bug. Any version control file should NOT be deleted inside the metadata.
Thanks

hotdp
24 Feb 2012, 1:15 AM
Do you have any idea about what sprint it will be in? Right now I am manually copying the folder. Its not the must fun thing to do...

I will blame my boss for not using Git!

aconran
24 Feb 2012, 9:03 AM
I will blame my boss for not using Git!
:-) Thats the spirit.

It's been bumped in priority and we are looking at it today.

Phil.Strong
27 Feb 2012, 10:47 PM
A fix has been submitted for testing. Expect this fix in the Wednesday release

hotdp
27 Feb 2012, 11:06 PM
A fix has been submitted for testing. Expect this fix in the Wednesday release

Awesome.