PDA

View Full Version : Sencha slice theme and ExtJS 4.1



burnnat
28 Feb 2012, 8:39 AM
I've found that I'm unable to use the sencha slice theme command with any of the 4.1 beta releases (the last release I'm able to slice is 4.0.7). Thinking it could be a problem with our custom theme, I tried running against the standard ext-all.css and obtained the same errors.

The command I'm using is:

sencha slice theme -c 4.1b3\resources\css\ext-all.css -d 4.1b3 -o images -v

And the output is:

Sencha Theme Generator
Copyright (c) 2011 Sencha Inc.

TypeError: 'undefined' is not a function
Line: 0
Source: undefined
TypeError: 'undefined' is not a function
Line: 0
Source: undefined
Error: Ext.Loader is not enabled, so dependencies cannot be resolved dynamically. Missing required class: Ext.util.Observable
Line: 0
Source: undefined
Error: Ext.Loader is not enabled, so dependencies cannot be resolved dynamically. Missing required class: Ext.util.Observable
Line: 0
Source: undefined
Error: Ext.Loader is not enabled, so dependencies cannot be resolved dynamically. Missing required class: Ext.data.Model
Line: 0
Source: undefined

Any suggestions for what could be wrong? It's really critical that we be able to slice our custom theme for IE! I'm running on Win7 x64, and I've tried using both SDK Tools 1.2.2 and 2.0.0 Beta, but both give the same results.

burnnat
28 Feb 2012, 8:47 AM
Ah, just saw this has already been reported in the 4.1 forum here (http://www.sencha.com/forum/showthread.php?182096-quot-sencha-slice-theme-quot-throwing-undefined-errors-and-halting-on-4.1). Sure would be nice to know if someone at Sencha is looking into this, as it is apparently affecting a large number of users...