PDA

View Full Version : [FIXED] Build 341 - SyntaxError - Parse error - Unable to save Project



CasualNetworks
1 Apr 2012, 11:04 PM
When I try to save my project I get the following error:

"SyntaxError - Parse error"

I also get this when going into the code view of "Application"

After exporting what components I could, I had to rebuild the project....

See attached zip for example

bluewwol
2 Apr 2012, 7:27 AM
I think this may be related, but I am unable to upgrade (open) a version 1.2 designer project with build 341. The prior version was able to do so. I do have an issue on my machine where I have JSON stores that are defined but not visible (network related issue on local machine) at the time of opening the project. The application thows and error then closes.

aconran
2 Apr 2012, 7:53 AM
When I try to save my project I get the following error:

"SyntaxError - Parse error"

I also get this when going into the code view of "Application"

After exporting what components I could, I had to rebuild the project....

See attached zip for example

There was a bug in 341, which has since been fixed and will be in the next release. It would occur when users had syntax errors in the init method of their Application.

aconran
2 Apr 2012, 7:54 AM
I think this may be related, but I am unable to upgrade (open) a version 1.2 designer project with build 341. The prior version was able to do so. I do have an issue on my machine where I have JSON stores that are defined but not visible (network related issue on local machine) at the time of opening the project. The application thows and error then closes.

This sounds like a different issue, although one that we may have fixed. We had a bug that was causing 1.x projects to attempt to go through the 2.x upgrade process (which isn't necessary).

CasualNetworks
2 Apr 2012, 12:22 PM
I tested the upgrade to the Designer 2 Build #353 today and this did resolve the problem on the project.