PDA

View Full Version : my application can't run in IE9 but it is ok in Chrome 17



xunxin
6 Apr 2012, 8:48 PM
there are a error when starting:

[Ext.createByAlias] Cannot create an instance of unrecognized alias: widget.navigator

scottmartin
7 Apr 2012, 7:54 AM
You have not provided very much information. Perhaps your define/create is not correct?
Missing views/requires in your controller?

Please provide your code for defining and creating the navigator.

Are you using the MVC pattern?

I suspect your construction is not correct.

Regards,
Scott.

xunxin
7 Apr 2012, 5:37 PM
yes ,i am using the MVC framework.

it work well after i add the requires config in the controller.

why it is necessary for IE9 but not for Chrome?

thanks for your reply.

scottmartin
8 Apr 2012, 5:55 AM
I suspect for the same reason IE will halt on an illegal comma, where other won't. (IE default settings)
The fact that it ran (or did not halt) does not mean that it was working correctly.

Scott.

xunxin
8 Apr 2012, 6:52 AM
thanks.