PDA

View Full Version : [INFOREQ] You're trying to decode an invalid JSON String: Source Class: Ext.JSON Source Metho



leopardo
9 Apr 2012, 5:37 AM
What's this? I don't open my project after update Build: 363.

"
An error occurred

You're trying to decode an invalid JSON String:


Source Class: Ext.JSON
Source Method: decode

"

help me.

aconran
9 Apr 2012, 10:05 AM
Please send an archive of your project to designer . feedback at sencha.com.

We'll try to figure out what the issue is.

leopardo
10 Apr 2012, 4:08 AM
I'am send the project for you verify.

Thank's

aconran
10 Apr 2012, 10:08 AM
Could you send me the backup archive that was created before updating the project? It will have a .xda extension and sit sibling to the directory the project resides in.

If you take a look at this, you'll see that the "Esquadro.xds" file has become corrupted. Not sure if this was done by the upgrade process or something externally.

leopardo
11 Apr 2012, 3:37 AM
The error message appeared even before backing up.In another project I was able to open, he made a backup in a directory.But in the case of 'Esquadro' Project the issued the error message even before you create the backup.

leopardo
11 Apr 2012, 3:55 AM
Now I understand what happened. The upgrade process corrupted the file Esquadro.xdsand I lost my project. In case I have other files, can not I generate the Esquadro.xds fromthe other not? Or a way to generate a new Esquadro.xds and add the files that I might notlose what you did?

aconran
11 Apr 2012, 9:55 AM
We make backups of the project before the upgrade. Do you have the backup archive?

leopardo
12 Apr 2012, 5:28 AM
No. I lose the file *.xds in my project. I try understand the file systems of designer to recreate this under hand.