PDA

View Full Version : No Ext JS 3 support in Sencha Architect, let's get back to Designer 2.0 Beta



jvandemerwe
23 Apr 2012, 4:53 AM
In Sencha Architect you can't make designs for Ext JS 3 anymore. This is understandible, but not nice. I have still a lot of legacy that sometimes needs to be extended. I know that upgrading it to Ext JS 4 would be much better, but since my customer doesn't want to invest in it now, nothing remains than stay in Ext JS 3 (with this customer that is).

But as Architect doesn't support Ext JS 3 anymore, I thought I install Sencha Designer 2.0 Beta again. This works fine, except I can't register anymore. After entering my credentials, it keeps on running around in accepting the terms and conditions and asking for my credentials.

How to act when you have bought Architect and still need Ext JS 3 functionality? Will Sencha drop Designer 2.0 for Architect? After using Designer so intensively, I feel a bit lost without it.

aconran
23 Apr 2012, 5:29 PM
Sencha Designer 2.0 Beta did not support Ext JS 3 either.

For users of Sencha Architect 2.0 that require Ext 3 support, we will gladly generate you a license for Ext Designer 1.2.x.

jvandemerwe
24 Apr 2012, 12:53 AM
You're right about that. I have digged up a version 1 and reinstalled it again, next to the Architect. That will do. Thank you for your reply.

heilen
28 Apr 2012, 10:03 AM
Hi! I'm running a similar problem.

We have an Ext Designer license and developed and app using it, we now want to migrate to Ext4 and bought the upgrade to Sencha Architect, in order to rewrite the app we want to use simultaneously Ext Designer and Sencha Architect (so that we can see what we have in one and replicate the design in the later).

Is there anyway you can provide me with the download link for Ext Designer? (I guess I have the original license lying around in my email)

Thanks!

Heilen

Stoot98
1 May 2012, 6:52 AM
I'd like to bump this thread as I'm looking for a download link for Ext Designer 1.2 as I've just moved to a new computer so need to reinstall it...

Thanks
Stuart

Phil.Strong
7 May 2012, 7:28 AM
http://extjs.cachefly.net/ext-designer/ExtDesigner-1.2.2-48.exe

http://extjs.cachefly.net/ext-designer/ExtDesigner-1.2.2-48.dmg

http://extjs.cachefly.net/ext-designer/ExtDesigner-1.2.2-48.run

http://extjs.cachefly.net/ext-designer/ExtDesigner-1.2.2-48-x64.run

jvandemerwe
7 May 2012, 7:29 AM
Great, thanks.

heilen
7 May 2012, 8:17 AM
thanks!

elentirmo
8 May 2012, 1:24 AM
Can you also provide download links for version 1.1? There are some bugs in 1.2 that prevent me from upgrading.

Phil.Strong
9 May 2012, 7:12 PM
http://extjs.cachefly.net/ext-designer/OLD/ExtDesigner-1.1.2-linux-installer.bin

http://extjs.cachefly.net/ext-designer/OLD/ExtDesigner-1.1.2-linux-x64-installer.bin

http://extjs.cachefly.net/ext-designer/OLD/ExtDesigner-1.1.2-windows-installer.exe

http://extjs.cachefly.net/ext-designer/OLD/ExtDesigner-1.1.2.dmg

elentirmo
9 May 2012, 11:03 PM
Thank you very much!

Phil.Strong
17 May 2012, 12:38 PM
I'll be working on fixing bugs in Ext Designer from now until it's done. Let me know if their are any you find especially hideous.

elentirmo
17 May 2012, 11:07 PM
Thanks for your attention!

The most important one for me is this one: http://www.sencha.com/forum/showthread.php?175481-DirectStore-directFn-property-is-lost-when-Ext-Direct-API-URL-is-empty&p=781874. This prevents me from upgrading from 1.1 to 1.2.

One thing I also noticed is that stores are no longer instantiated automatically: the "Instantiate stores" option in the project preferences is gone, and stores are not created automatically like they used to be in 1.1. I can of course work around this, but due to the size of my projects I would rather see a fix in Designer.

Finally, it would really make my life a lot easier if this feature could be added: http://www.sencha.com/forum/showthread.php?129389-DISCUSS-Expand-component-tree-to-selection. However I appreciate that this might be asking a bit too much for a bug fix release :-)

yozefff
18 May 2012, 2:15 AM
yeah ... the store problem is really a pain in the a** ... I have the same problem .. yes I can work around it , but that's not what I paid for (it used to work).

oh .. about the licences ...

So I have ExtJS3 projects (Designer 1) but also upcomming Touch2 projects (Architect) ... If I upgrade from Designer to Architect ... Do I still have a license for Desginer for future updates? Because I need Designer for my ExtJS3 projects. But I also want to developer for ExtJS4 and Sencha Touch2.

Phil.Strong
18 May 2012, 9:31 AM
yeah ... the store problem is really a pain in the a** ... I have the same problem .. yes I can work around it , but that's not what I paid for (it used to work).

oh .. about the licences ...

So I have ExtJS3 projects (Designer 1) but also upcomming Touch2 projects (Architect) ... If I upgrade from Designer to Architect ... Do I still have a license for Desginer for future updates? Because I need Designer for my ExtJS3 projects. But I also want to developer for ExtJS4 and Sencha Touch2.

Of course you do. No worries here.

Phil.Strong
18 May 2012, 9:36 AM
Thanks for your attention!

1 - The most important one for me is this one: http://www.sencha.com/forum/showthread.php?175481-DirectStore-directFn-property-is-lost-when-Ext-Direct-API-URL-is-empty&p=781874. This prevents me from upgrading from 1.1 to 1.2.

2 - One thing I also noticed is that stores are no longer instantiated automatically: the "Instantiate stores" option in the project preferences is gone, and stores are not created automatically like they used to be in 1.1. I can of course work around this, but due to the size of my projects I would rather see a fix in Designer.

3- Finally, it would really make my life a lot easier if this feature could be added: http://www.sencha.com/forum/showthread.php?129389-DISCUSS-Expand-component-tree-to-selection. However I appreciate that this might be asking a bit too much for a bug fix release :-)

1. We fixed this in Architect so asking Bharat, who worked on it, to weigh in on this one.
2. I'll see what I can do here. I'm pretty sure we instantiate them in Architect so could simply be a patch.
3. While it would be nice, we are doing a non feature release. Bugs only

jasonsti
24 May 2012, 9:11 PM
good to see the links for the older versions, but one problem, there is a server error when it comes to activation, any one else having this problem???

aconran
24 May 2012, 11:18 PM
good to see the links for the older versions, but one problem, there is a server error when it comes to activation, any one else having this problem???
If you have an active license for your forum username and are still getting a server error please contact support@sencha.com. We are no longer providing trials for Ext Designer.

silentkid
24 Jul 2012, 6:52 PM
Hi,

I am currently dealing with ExtJs 3.4 projects now, I tried the two installer here and when I tried to register with my account, it gave a a "server error" message. May I know why is this ?

aconran
25 Jul 2012, 8:21 AM
Hi,

I am currently dealing with ExtJs 3.4 projects now, I tried the two installer here and when I tried to register with my account, it gave a a "server error" message. May I know why is this ?

New trials have been turned off since the release of Architect 2. If you previously purchased a license to Ext Designer and/or have bought a license to Sencha Architect, please email designer.feedback at sencha.com and we will activate your account with your licensing info.