PDA

View Full Version : Disable cache parameter not working



whirling dervish
30 Jul 2012, 8:17 AM
I am trying to disable the anti-cache timestamp parameter that ExtJS prepends to all requests by setting it to off,



Ext.Loader.config.disableCaching =false;



Unfortunately this isn't working.

Right now I have this in a script block above where I import my main app script. Is there the wrong place to set globals like this?

scottmartin
30 Jul 2012, 1:04 PM
Please see if this helps:



proxy: {
noCache: false
}


Scott

whirling dervish
31 Jul 2012, 5:30 AM
Nope, I commented out my failed attempts and tried putting that into my script block but unfortunately that didn't work either.

scottmartin
31 Jul 2012, 11:06 AM
Can you provide more detail? Please

I added the following to my Model::proxy and it removed the param



Ext.define('Model', {
extend: 'Ext.data.Model',
proxy: {
type: 'ajax',
noCache: false,
..
}
});

store = new Ext.data.Store({ // not jsonStore
model: 'Model',
// config
});


index.php/users/list_users/
before:
index.php/users/list_users/?_dc=1343761343142

Scott.

whirling dervish
31 Jul 2012, 11:13 AM
Sorry Scott, I spazed out and put the proxy in my initial script like it was some kind of global setting

Once I added noCache: false to my proxy it did disable the anti cache feature.

Thanks.