PDA

View Full Version : [INFOREQ] Unexpected error on model identifier editing



pcki11
15 Aug 2012, 4:30 AM
Architect 2.1.0 build 584 / Mac OS X 10.7.4
When I try to change an identifier of a model in object edit mode, architect displays error message:

TypeError: 'undefined' is not an object
It is displayed each time I type something in the editor panel. It is completely messed up, in string mode the changes are not displayed in properties of a model.

After a couple of such error messages i saved the project, and when I reopened it there were no views and no controllers. God bless CVS =)

aconran
15 Aug 2012, 9:45 AM
Architect 2.1.0 build 584 / Mac OS X 10.7.4
When I try to change an identifier of a model in object edit mode, architect displays error message:

TypeError: 'undefined' is not an object

Do you mean you are editing the data configuration of a store (it's identifier)?

Or do you mean you are editing the identifier configurations of model?

Could you show us some screenshots and/or more detailed info so we can figure out what the problem is?

pcki11
15 Aug 2012, 11:25 AM
I am editing configuration of a model. I think the problem is that you run validation each time that a key is entered in the identifier object editor, because I managed to update configuration of my models by pasting the code. Also, it is somewhat not obvious that in the new object editor you need to provide the actual object, i.e.
{type: "uuid"} and not
type: "uuid" The latter is more intuitive, given that when you edit a controller action for example, you dont have to wrap your code in curly brackets.

Attaching screenshot.