PDA

View Full Version : Problem when loading a list for the second time



bensam90
16 Aug 2012, 4:08 AM
Hi,

I am creating a sample app where i use list in a lot of areas.Now i have come across a problem.When i load a list for the first time the data will come without any problem,but when i go back and try to load the list again nothing happens.Can anyone clarify why this is happening...

Regards,
bensam90

tine_m
17 Aug 2012, 2:13 AM
if you are using list without a store try (re)loading data like this:


if (myList.getStore() != null)
myList.getStore().removeAll();
myList.setData(newData);

bensam90
17 Aug 2012, 2:24 AM
The problem is that when i tap on a list item ,then page navigation occurs.But when i go back and try to tap another item list, no navigation occurs.I checked and see that the first data,is being loaded again for every other list item.this is caused only when i try to navigate from a list to another page when taped on the item.otherwise there is no problem.

tine_m
17 Aug 2012, 2:37 AM
Can you provide an example how you load your list and itemtap listener?

bensam90
17 Aug 2012, 2:46 AM
Yaa.
I don't have the code ri8 now.But i will give you an idea.

I have a list containing say AGENT & CUSTOMER as the items..on tapping any 1, i navigate to another page.The tap action is made possible by fetching the index.If i tap on Agent say index is 0 it will navigate to another page and for Customer index is 1 then navigate to other page.If i tap on Agent/Customer for the first time, it navigates fine and the data to the page is coming,but if i go back and try to tap Agent or Customer then no navigation occurs, but i don't get any error.and i tried to show the data on the console ,it is showing the data which came for the first attempt every time i tap,but no navigation.This is the rough sketelon..I will share the code i used soon..