PDA

View Full Version : Getting Java script error when submitting the Field Container Editable Row



Kannan K
4 Sep 2012, 12:32 AM
Hi,
I have the Editable Row Grid that contains one of the editor column having the 'FieldContainer' that I am rendering with two TextArea. The problem here is when I submit this editable row, I am getting the script error which is throwing from the inbuilt 'validateEdit' functionality of Ext-all.js.
Please refer the code below

text: 'Log Entry',
//width: 290,
flex: 1,
sortable: true,
dataIndex: 'logEntry',
editor: {
xtype: 'fieldcontainer',
items: [{
xtype: 'textarea',
style:'margin-top:7px;',
height: 35,
width: 220
//flex: 1
}
, {
xtype: 'textarea',
id: 'leEnd',
height: 35,
width: 220
//flex: 1
}]
/*xtype: 'textarea',
height: 30*/
}

So please help me out how to get rid of from the Script error. Is there a way to override the inbuilt functionality or is there any other way to handle the field container in the editable grid row.

mitchellsimoens
17 Sep 2012, 6:39 AM
What do you mean submit it? You shouldn't be submitting anything.