PDA

View Full Version : ExtJS 4.1.1 Accessibility support



rishinarang007
5 Sep 2012, 8:36 PM
I want to add Accessibility support in extjs 4.1.1 components, i have looked at the accessibility video on sencha websites, is there are any documentation available which tells the methods to be overridden for adding custom accessibility messages, I understand ariaRole property is there and needs to be overridden in config, I want all the properties/ methods available in every extjs component.

Do I need to add my custom key events in every component so that screen readers can understand?

I need to follow guidelines like this: http://www.w3.org/TR/wai-aria-practices/#accessiblewidget

Thanks
Rishi

scottmartin
6 Sep 2012, 12:08 PM
Support for ARIA is slated for 4.2 at this time.

Scott.

rishinarang007
6 Sep 2012, 8:03 PM
Thanks, Is 4.2 release expected by end of 2012?

scottmartin
7 Sep 2012, 4:15 AM
There is no public release date available at this time.

Scott.

revolver
26 Apr 2013, 8:56 AM
The previous reply to this question was "support for ARIA is slated for 4.2 at this time." Now that 4.2 is available, it does not appear to be fully compliant. Is ARIA support now slated for a new 4.x release? Which one?

Thanks.

muralisk477
7 Jan 2014, 2:30 AM
How to use ARIA 2.0 "ariadescribed-by" property in ExtJs 4.2 components?? in ExtJs4.2 we have only ariaRole config property.. how to implement other ARIA properties??