PDA

View Full Version : 2.1.0 B2 issues



grizzly21
7 Sep 2012, 1:31 AM
Hi,

I tried to use the latest sdk 2.1. beta2 and the first thing I saw was the views got totally messed up. Some elements on the page that shouldn't have been there, some were just on the wrong places, etc. Even the buttons looked awful. No errors whatsoever, but the layout is totally messed up..

Is this something everyone else would expect from this release or it would be a problem on my end? Should I just use the latest non beta sdk ?

thanks!

grizzly21
7 Sep 2012, 2:02 AM
Also, where can I download the latest stable (2.0.2) sdk ? I can't seem to find it anywhere on this site..

grizzly21
10 Sep 2012, 2:51 AM
Up!
Also: I'm using the latest Architect.

mitchellsimoens
10 Sep 2012, 4:46 AM
2.1.0 b2 had some layout perf fixes but things were a little messed up. 2.0.2 is a support subscriber only release as is 2.0.3. 2.1.0 b3 is due out very soon.

grizzly21
10 Sep 2012, 4:48 AM
All right. So in the interim I'm using 2.1.0.b1, that seems to be working fine regarding the views..

grizzly21
13 Sep 2012, 1:26 AM
So now that beta3 is out I tried it and it looks the same as beta2: some views appear where they shouldn't, some element scale full screen where they should be small fix sized windows, etc. Is this still not fixed, or is it the way it's going to work like from now on?

mitchellsimoens
13 Sep 2012, 4:20 AM
Maybe you should provide a test case of it not working so we would know what's not working. There is a bugs forum

grizzly21
13 Sep 2012, 6:17 AM
Maybe you should provide a test case of it not working so we would know what's not working. There is a bugs forum

It can be hard to provide a test case, because it's already a big application, but if there's no other way I will try to come up with something.

Also worth noting I'm using Architect (latest). Noone experienced this other than me? It really looks like the same layout issues as in beta 2.
Maybe if I post a few screenshots that could help?