PDA

View Full Version : Deploy of 1 View fails



Lunti
18 Sep 2012, 11:03 PM
Deploy of a Panel fails Architect Build tested:

Version 2.1.0
Build 613

Project Type:

ExtJS 4.1

Description:

While developing I wanted to deploy and test the project.
Sencha Architect deployed all files but one.
There's no clue why - I have a panel that has everithing in common but the class and alias name and that panel was deployed.
The panel is listed in views[] of the application.
By manually creation of this file by just copying the generated code in Sencha Architect, it works just fine.

Steps to reproduce the problem:

I can provide the project if you want - I don't have the time to figure out more about it.

The result that was expected:

view should be deployed

The result that occurs instead:

view wasn't deployed, ending in an error 404 (missing the view-file)

HELPFUL INFORMATION Screenshot, Project, or Video:

38773
38774

Possible fix:

not provided

Operating System:

WinXP Pro

Phil.Strong
19 Sep 2012, 7:21 AM
sent you a PM

Phil.Strong
20 Sep 2012, 6:27 AM
I got your project looking at it now

Phil.Strong
20 Sep 2012, 6:40 AM
I deployed the project you sent me and all 5 views plus Viewport.js (6).

It runs fine once I switched where the framework was loaded from.

Lunti
20 Sep 2012, 7:02 AM
http://dl.dropbox.com/u/22897509/appJS.gif
http://dl.dropbox.com/u/22897509/projectInspector.gif

and after deployment that's the errormessage:
http://dl.dropbox.com/u/22897509/error404.gif

Even after restart of Sencha Architect.