PDA

View Full Version : [FIXED] 3.0.0.181 bug with French characters?



huberte
1 Oct 2012, 6:46 PM
I updated to new version. App is fine in local, was fine with old stbuild, produces weird character in place of à, è, now :-(

With
sencha ant build production or testing
Or
sencha app package production or testing.

Thks

dongryphon
1 Oct 2012, 11:56 PM
Thanks for the report! I have opened a bug in our bug tracker.

huberte
2 Oct 2012, 7:24 PM
Thanks

My tab is "Démarrer" eg "Start"

here is a short code from app.js when I build production or testing :


,title:"Démarrer",

huberte
5 Oct 2012, 3:38 PM
still the case with 3.0.0.190 !!

dongryphon
5 Oct 2012, 9:51 PM
Yes, we are still working on this and this page is still marked "OPEN" :)

We have to determine the charset of arbitrary JS files in order to build them together with other JS files that are using a different encoding. And then there is the markup file as well, but at least that one can describe its charset in a meta tag.

The current plan is to allow JS files to do something like this on the first line to declare their encoding:



//@charset windows-1255


or



//@charset ISO-8859-2


The default would be equivalent to:



//@charset utf-8


As for output, the plan is to always output UTF-8 for "all-classes.js" but we may yet add an option to control that.

Please watch the status of this thread for updates on this issue. We haven't forgotten. :)

ingo.hefti
5 Oct 2012, 11:02 PM
There is a second bug in your bugtracker that looks like this one here: [/URL]http://www.sencha.com/forum/showthread.php?245082-In-3.0.0.181-quot-app-all.js-is-using-ANSI-not-UTF8-quot-breaks-localization (http://<a href=&quot;[url]http://www.sencha.com/forum/showthread.php?245082-In-3.0.0.181-quot-app-all.js-is-using-ANSI-not-UTF8-quot-breaks-localization&quot; target=&quot;_blank&quot;>http://www.sencha.com/forum/showthread.php?245082-In-3.0.0.181-quot-app-all.js-is-using-ANSI-not-UTF8-quot-breaks-localization</a>)

What I don't understand: this used to work before. What could possibly be the reason you had to change something to break this?

dongryphon
5 Oct 2012, 11:17 PM
Indeed they look like duplicates. Thanks.

As you can tell from my description of the solution we are working on, this problem goes rather deep. Since no previous versions have ever had concrete declarations of charset of individual JS files, it has always been a fragile thing. What worked in some scenarios would fail in others. Fixing those could break those that worked. The only way to be 100% correct here is for the files to describe their encoding.

ingo.hefti
5 Oct 2012, 11:21 PM
Since no previous versions have ever had concrete declarations of charset of individual JS files, it has always been a fragile thing. What worked in some scenarios would fail in others. Fixing those could break those that worked. The only way to be 100% correct here is for the files to describe their encoding.
That sounds very reasonable. Thanks for explaining. Hope we get a fix soon as this is extremely annoying.

Just for my own curiosity: you are located in what timezone?

dongryphon
5 Oct 2012, 11:23 PM
That sounds very reasonable. Thanks for explaining. Hope we get a fix soon as this is extremely annoying.

Sure thing. :)


Just for my own curiosity: you are located in what timezone?

USA Central (GMT-6:00)... so a bit late (2:30am).. :)

ingo.hefti
5 Oct 2012, 11:25 PM
USA Central (GMT-6:00)... so a bit late (2:30am).. :)
Thank you for your very late working then! =D>

huberte
6 Oct 2012, 9:28 PM
The default would be equivalent to:



//@charset utf-8


As for output, the plan is to always output UTF-8 for "all-classes.js" but we may yet add an option to control that.

Please watch the status of this thread for updates on this issue. We haven't forgotten. :)

I know you don't forget :)

I had many hopes in 190.... ;)

why isn't utf8 working for everyone ?


There is a second bug in your bugtracker that looks like this one here: http://www.sencha.com/forum/showthread.php?245082-In-3.0.0.181-quot-app-all.js-is-using-ANSI-not-UTF8-quot-breaks-localization

What I don't understand: this used to work before. What could possibly be the reason you had to change something to break this?

Saw that too, couple of days ago

thang_ibrahim
11 Oct 2012, 5:32 PM
Hoping to fix this issue

dongryphon
11 Oct 2012, 7:47 PM
Hoping to fix this issue

Me too :)

When the next build is out I hope you can let us know if we've missed something yet on this one.

Thanks for all your help!

ingo.hefti
24 Oct 2012, 12:12 AM
Just tried CMD...201 - and my 'special' chars are working again! Thanks for that!!