PDA

View Full Version : Need a reminder on using the upgrade command please



parky128
4 Oct 2012, 6:32 AM
Hi,

I have just downloaded the Sencha Touch 2.1.0.RC1 and need to upgrade my existing version (on 2.1.0.b3).

I have Cmd installed and have been using it already (build 141).

Can someone remind me, do I need to cd into the path of the new SDK or my app first before issuing the upgrade command?

Thanks

TetsuBo
4 Oct 2012, 6:49 AM
Go to your app dir and use "sencha app upgrade -p /path/to/new_sdk"

parky128
4 Oct 2012, 7:02 AM
Thanks thats what I thought, but I am getting an error:


C:\Sencha\Projects\PPTouch>sencha app upgrade -p C:/Sencha/ST.2.1.0.RC1
Sencha Cmd v3.0.0.141
[ERROR] Cannot find C:\Sencha\Projects\PPTouch\.sencha\app\${workspace.c
onfig.dir}\plugin.xml imported from C:\Sencha\Projects\PPTouch\.sencha\app\plugi
n.xml


Where am I going wrong? Thanks

svenna
4 Oct 2012, 10:16 PM
Upgrade to Cmd 188. The upgrade command was not complete i .141 AFAIK.

However, be aware that the upgrade overwrites some of your project files.
At least 181 overwrote img resources and package.json. 181 overwrote package.json, not sure about the images.

dongryphon
5 Oct 2012, 2:28 PM
Thanks for helping folks. Indeed 141 had a broken upgrade command. See http://www.sencha.com/forum/showthread.php?243153-Sencha-Cmd-V3-Beta for the latest build (now 190).