PDA

View Full Version : Problem installing Eclipse Plugin: "Cannot complete the install because of a conflict



mwunderlich
9 Oct 2012, 7:39 AM
Hi,

I am having some difficulties in installing the Eclipse Plugin for Sencha ExtJS (on Eclipse Indigo), see error msgs below. There are conflicting dependencies, but I am not sure how they can be resolved.
Any ideas?
Thanks a lot.

Kind regards,
Martin




Cannot complete the install because of a conflicting dependency.
Software being installed: Sencha Eclipse Plugin - 30 day trial 1.0.0.201209102350 (com.sencha.vjet.extjs.trial.feature.feature.group 1.0.0.201209102350)
Software currently installed: Eclipse IDE for Java EE Developers 1.4.0.20110615-0550 (epp.package.jee 1.4.0.20110615-0550)
Only one of the following can be installed at once:
Core Resource Management 3.7.101.v20120125-1505 (org.eclipse.core.resources 3.7.101.v20120125-1505)
Core Resource Management 3.7.100.v20110510-0712 (org.eclipse.core.resources 3.7.100.v20110510-0712)
Cannot satisfy dependency:
From: License 1.0.0.201209102350 (com.sencha.vjet.extjs.ftp 1.0.0.201209102350)
To: bundle org.eclipse.core.resources 3.7.101
Cannot satisfy dependency:
From: Sencha Eclipse Plugin - 30 day trial 1.0.0.201209102350 (com.sencha.vjet.extjs.trial.feature.feature.group 1.0.0.201209102350)
To: com.sencha.vjet.extjs.ftp [1.0.0.201209102350]
Cannot satisfy dependency:
From: Eclipse IDE for Java EE Developers 1.4.0.20110615-0550 (epp.package.jee 1.4.0.20110615-0550)
To: org.eclipse.epp.package.jee.feature.feature.group [1.4.0.20110615-0550]
Cannot satisfy dependency:
From: Java EE IDE Feature 1.4.0.20110615-0550 (org.eclipse.epp.package.jee.feature.feature.group 1.4.0.20110615-0550)
To: org.eclipse.platform.feature.group [3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f]
Cannot satisfy dependency:
From: Eclipse Platform 3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f (org.eclipse.platform.feature.group 3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f)
To: org.eclipse.core.resources [3.7.100.v20110510-0712]

scottmartin
9 Oct 2012, 7:50 AM
Here is a great video on getting started:
http://www.youtube.com/watch?v=smBwNyZQEhg

Scott.

mwunderlich
9 Oct 2012, 8:02 AM
Thank you for the quick reply, Scott, but unfortunately my specific problem of conflicting dependencies is not addressed in the video.

scottmartin
9 Oct 2012, 8:09 AM
Only one of the following can be installed at once:

Do you have a previous install? the other suggestion would be to check for conflicts with other plugins. Can disable select plugins to check?

You may want to try a clean install.

Scott.

mwunderlich
9 Oct 2012, 11:06 PM
Hi Scott,

I have managed to install the Plugin for ExtJS now. In the end, I went for a clean re-install of Eclipse. The problem might have been down to conflicting Java versions installed: I had a JRE6 installation, but the Java Home environment variable was pointing to a JRE6 installation in some Adobe directory. Also, there was a JRE7 installation, but a 32bit one, not the required 64 bit. After installation the 64bit version of JRE7 and reinstalling Eclipse Indigo (3.7.2), I managed to install the Plugin as per the installation instructions. Time to start coding...

Cheers,
Martin