PDA

View Full Version : Compatibility Pack Issues with 4.1



kerbo
1 Nov 2012, 8:35 AM
I started the process to port our application from 3.4 to 4.1 and I am getting lots of Deprecation warnings with ext-all-debug, for example:

[DEPRECATED][4.0][Date] getShortMonthName: Use Ext.Date.getShortMonthName instead.

Is this an issue because the compatibility pack is old?

Is there any way to suppress messages from ext-all-debug?

skirtle
3 Nov 2012, 1:33 AM
That sounds like the Compatibility Pack working exactly as intended. You need to go through your code and update it to not use the deprecated methods. Then you can remove the Compatibility Pack.

That said, I'd be wary of using the Compatibility Pack against 4.1. I don't believe it has been updated since 4.0 so there are no guarantees about how stable it will be. It may be a useful guide to upgrading but don't expect to be able to get your app fully functional with it.