PDA

View Full Version : [2.1] app blocker on tablet (Android)



ingo.hefti
16 Nov 2012, 10:15 AM
Native JakoaCRM app: I have that long list in a view (normal list component). When I place several fingers on several list items at the same time, most of them get selected (light selection color). I can deselect the list items, but the list / app remains locked. Nothing is movable anymore. I have to kill the app to reuse it.

This happens on the Acer a500 tablet with Android V4.0.3.
I was not able to reproduce it on one of my phones.

Following is the logcat when the app is launched until it gets locked:


--------- beginning of /dev/log/system
I/ActivityManager( 140): START {act=android.intent.action.MAIN cat=[android.intent.category.HOME] flg=0x10200000 cmp=com.android.launcher/com.android.launcher2.Launcher} from pid 140
--------- beginning of /dev/log/main
D/OpenGLRenderer(29663): Flushing caches (mode 1)
I/ActivityManager( 140): No longer want com.google.android.apps.maps:FriendService (pid 29931): hidden #16
I/ActivityManager( 140): START {act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=com.jakoa.JakoaCRM/.STActivity bnds=[208,458][304,554]} from pid 408
D/dalvikvm(30258): Late-enabling CheckJNI
I/ActivityManager( 140): Start proc com.jakoa.JakoaCRM for activity com.jakoa.JakoaCRM/.STActivity: pid=30258 uid=10065 gids={3003, 1006}
I/dalvikvm(30258): Turning on JNI app bug workarounds for target SDK version 8...
D/OpenGLRenderer( 408): Flushing caches (mode 1)
D/OpenGLRenderer( 408): Flushing caches (mode 0)
D/dalvikvm( 140): GC_CONCURRENT freed 1200K, 32% free 12206K/17927K, paused 4ms+8ms
V/TabletStatusBar( 218): setLightsOn(true)
W/InputManagerService( 140): Starting input on non-focused client com.android.internal.view.IInputMethodClient$Stub$Proxy@414e4a20 (uid=10057 pid=29663)
I/ActivityManager( 140): Displayed com.jakoa.JakoaCRM/.STActivity: +329ms
D/dalvikvm(30258): GC_CONCURRENT freed 177K, 5% free 6827K/7111K, paused 6ms+3ms
D/libEGL (30258): loaded /system/lib/egl/libEGL_tegra.so
D/libEGL (30258): loaded /system/lib/egl/libGLESv1_CM_tegra.so
D/libEGL (30258): loaded /system/lib/egl/libGLESv2_tegra.so
E/libEGL (30258): call to OpenGL ES API with no current context (logged once per thread)
D/ShaderProgram(30258): couldn't load the vertex shader!
E/libEGL (30258): call to OpenGL ES API with no current context (logged once per thread)
D/ShaderProgram(30258): couldn't load the vertex shader!
E/libEGL (30258): call to OpenGL ES API with no current context (logged once per thread)
D/ShaderProgram(30258): couldn't load the vertex shader!
E/libEGL (30258): call to OpenGL ES API with no current context (logged once per thread)
D/ShaderProgram(30258): couldn't load the vertex shader!
E/libEGL (30258): call to OpenGL ES API with no current context (logged once per thread)
D/ShaderProgram(30258): couldn't load the vertex shader!
I/Web Console(30258): onNavigationViewPush: directorycompanysearchview at file:///android_asset/app.js:1
D/dalvikvm( 313): GC_CONCURRENT freed 506K, 26% free 8532K/11399K, paused 2ms+2ms
D/dalvikvm( 218): GC_CONCURRENT freed 1260K, 73% free 7976K/29191K, paused 2ms+14ms
D/AudioFlinger( 84): Disable natural base
V/NvAudioALSA( 84): open called for devices 00000002 in mode 0...
V/NvAudioALSA( 84): getAlsaDeviceName::devices 0x2 IsVoiceCallDevice 0 devName music
V/NvAudioALSA( 84): Reset buffer size to 4096 and latency to 92879
V/NvAudioALSA( 84): Set PLAYBACK PCM format to S16_LE (Signed 16 bit Little Endian)
V/NvAudioALSA( 84): Using 2 channels for PLAYBACK.
V/NvAudioALSA( 84): Set PLAYBACK sample rate to 44100 HZ
V/NvAudioALSA( 84): Buffer size: 4096
V/NvAudioALSA( 84): Period size: 1024
V/NvAudioALSA( 84): Latency: 92879
V/NvAudioALSA( 84): Period Time: 23219
V/NvAudioALSA( 84): Periods: 4
V/NvAudioALSA( 84): Initialized ALSA PLAYBACK device music
V/NvAudioALSA( 84): Closing ALSA device!, curDev 0x2, curMode 0
W/webview (30258): Miss a drag as we are waiting for WebCore's response for touch down.
D/dalvikvm( 218): GC_CONCURRENT freed 90K, 72% free 8329K/29191K, paused 2ms+4ms
D/dalvikvm( 218): GC_CONCURRENT freed 20K, 70% free 8829K/29191K, paused 2ms+4ms
D/OpenGLRenderer( 218): Flushing caches (mode 0)
W/InputManagerService( 140): Starting input on non-focused client com.android.internal.view.IInputMethodClient$Stub$Proxy@4192f570 (uid=10065 pid=30258)

mitchellsimoens
19 Nov 2012, 10:51 AM
But the same works if you only use 1 finger?

ingo.hefti
19 Nov 2012, 1:48 PM
But the same works if you only use 1 finger?
Yes, it does work with a single finger.

But if you accidentally place a second one then you are screwed. And this happens more often then you would like. In the meantime I checked on a Samsung 10 tablet with Android V4.0.3: exactly the same behavior.

What's interesting: this seems to be some sort of multi-selection mode that is active for that list. And I never succeeded to intentionally do the same on a smartphone. This seems to happen only on tablets.

andrew01210
20 Nov 2012, 11:51 AM
This sounds similar to what I am experiencing

REQUIRED INFORMATION


Ext version tested:

Sencha Touch 2.1.0
Browser versions tested against:

Android Samsung Galaxy SII 4.0.3
Description:

After performing a pinch gesture the app seems to stop firing touch events, ie scrolling no longer works and nothing happens when tapping buttons. Does not reproduce 100% of the time but it should be easy (less than 5 pinches)
Performing another pinch gesture when the app is in the state above will sometimes resume event firing but this is harder to reproduce.
I have only reproduced this when running as a native app, no issues when running from browser on Android
Steps to reproduce the problem:

generate a new app with Sencha Cmd 3 (standard Welcome to Sencha Touch 2 app)
packag and deploy build to Android
perform a pinch gesture after the app has launched
try to scroll the view
tap Get Started tab button
The result that was expected:

the view scrolls
Get Started view is displayed
The result that occurs instead:

no scrolling takes place
the view does not change, though you can see the tab button text turn white while tapped

ingo.hefti
20 Nov 2012, 2:10 PM
and another one: http://www.sencha.com/forum/showthread.php?249581-Multi-touch-and-phonegap...

ingo.hefti
29 Nov 2012, 3:02 AM
so this is not considered to be a bug?