PDA

View Full Version : [FIXED] Error when compiling gxt.jar



kcaseye
21 Apr 2008, 5:46 AM
I get this error when I compile using the gxt.jar file that I downloaded from this site.


bad class file: F:\Isaac\AdminClient\gxt-1.0-beta1\gxt.jar(com/extjs/gxt/ui/client/mvc/AppEvent.class)
class file has wrong version 50.0, should be 49.0
Please remove or make sure it appears in the correct subdirectory of the classpath.
import com.extjs.gxt.ui.client.mvc.AppEvent;
1 errorOS: Windows XP
IDE: Netbeans with GWT4NB plugin

(I have compiled with MyGWT 0.5.2 using Netbeans, so I don't think that's the problem.)

jayj
21 Apr 2008, 6:57 AM
gxt 1.0 needs JDK 1.5.

kcaseye
21 Apr 2008, 7:08 AM
I'm using jdk 1.5. That's not the problem.

darrellmeyer
21 Apr 2008, 7:42 AM
The problem is that gxt.jar contains 1.6 bytecode.

49.0 = 1.5
50.0 = 1.6

I have fixed the build to produce 1.5 bytecode. The changes are in SVN and will go out in the next rev.

For a workaround, you can use JDK 1.6. Let me know if you still have problems.

kcaseye
21 Apr 2008, 9:18 AM
When will the next revision come out? And how often do revisions come out in general?

gslender
22 Apr 2008, 3:02 AM
darrell, this kind of bug is where you shouldn't be waiting for the next release ... clearly if Ext GXT needs 1.6 than fair enough, but this is actually stopping people from using 1.0 as, like me, they probably don't want to upgrade their VM as this can cause other incompatiblities - lucky for me I grabbed a snapshot of the SVN a few days ago and can continue working... :(

darrellmeyer
23 Apr 2008, 9:00 AM
There will be a rapid release cycle while we are in beta. Beta2 will be available soon.

rreckel
25 Apr 2008, 12:47 AM
I really need a gxt.jar which is compiled with jdk5 .....
There is no official jdk6 on mac osx, and even the dev preview of jdk6 doesn't work in hosted mode.

So for now I am really blocked!

Thanks a lot
Roll

darrellmeyer
25 Apr 2008, 7:15 AM
Beta2 will be up by Monday.