PDA

View Full Version : [FIXED] Error trying to set style attribute



cdasher
24 Apr 2008, 6:21 AM
I am trying to use a Form and set disabled for everything dynamically. Everything works but the opacity for the disabled style is too light for my tastes so I call setAttribute("opacity","0.8") and I get the following error:
this.setOpacity is not a function
setStyle("opacity", "0.8")E71DD1CB425E97FAA... (line 3794)
applyStyles(input#my-153.x-form-field sd, "opacity:0.8;")E71DD1CB425E97FAA... (line 2570)
applyStyles("opacity:0.8;")E71DD1CB425E97FAA... (line 3328)
com_extjs_gxt_ui_client_core_Ext_call__Lcom_google_gwt_user_client_Element_2Ljava_lang_String_2Ljava_lang_String_2(input#my-153.x-form-field sd, "applyStyles", "opacity:0.8;")E71DD1CB425E97FAA... (line 2123)
com_extjs_gxt_ui_client_core_El_$applyStyles__Lcom_extjs_gxt_ui_client_core_El_2Ljava_lang_String_2(null, "opacity:0.8;")E71DD1CB425E97FAA... (line 1338)
etc. etc.
What is the proper way to override a style attribute.

darrellmeyer
24 Apr 2008, 7:30 AM
There was a bug with opacity that has been fixed in SVN.

cdasher
24 Apr 2008, 10:20 AM
Cool thanks I am waiting on a approval for the PO to get a couple of devleoper licenses and then I will have svn access :)