PDA

View Full Version : Error loading EXT GWT



msandy
2 May 2008, 9:51 PM
I get this error when trying to load my GWT project in which I have added EXT GWT. My eclipse GWT project uses JRE 1.4 and has compiler compliance level set to 1.4.

Any help in getting started would be appreciated.


[ERROR] Line 5: Unexpected exception while processing element 'inherits'
java.lang.UnsupportedClassVersionError: com/extjs/gxt/ui/rebind/core/TemplateFactoryGenerator (Unsupported major.minor version 49.0)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1255)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1189)
at com.google.gwt.dev.cfg.ModuleDefSchema$ObjAttrCvt.convertToArg(ModuleDefSchema.java:493)
at com.google.gwt.dev.util.xml.HandlerArgs.convertToArg(HandlerArgs.java:64)
at com.google.gwt.dev.util.xml.HandlerMethod.invokeBegin(HandlerMethod.java:214)
at com.google.gwt.dev.util.xml.ReflectiveParser$Impl.startElement(ReflectiveParser.java:242)
at org.apache.xerces.parsers.AbstractSAXParser.startElement(AbstractSAXParser.java:454)
at org.apache.xerces.impl.XMLNamespaceBinder.startElement(XMLNamespaceBinder.java:571)
at org.apache.xerces.impl.dtd.XMLDTDValidator.startElement(XMLDTDValidator.java:756)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanStartElement(XMLDocumentFragmentScannerImpl.java:752)

gslender
2 May 2008, 10:17 PM
Ext GWT 1.0b2 requires JDK 1.5 and GWT 1.5M2