PDA

View Full Version : API : MenuItem



zaccret
26 May 2008, 3:28 AM
I find the menu item API a little confusing.
We have MenuItem <- Item <- TextMenuItem.
The name choice is confusing (Item <- MenuItem <- TextMenuItem would be more intuitive) and TextMenuItem has no more features than Item.

gslender
26 May 2008, 12:53 PM
+1

But perhaps Item could just be refactored to SubMenuItem which is what its purpose and/or name is really??? I don't think Item is used anywhere else???

darrellmeyer
26 May 2008, 5:28 PM
Yes, the hierarchy is a little silly :-). I have made the following changes: MenuItem is renamed to Item. Item is renamed to MenuItem. TextMenuItem is removed as it provided no additional features to its super class. The changes are in SVN.

zaccret
26 May 2008, 10:14 PM
Nice. Thanks.

zaccret
18 Jun 2008, 12:00 AM
Actually, I think it would be better to rename Item to MenuItem and MenuItem to TextMenuItem.

sdc
3 Jul 2008, 6:32 AM
+1