PDA

View Full Version : Qtips Display Issue



mikegiddens
2 Apr 2007, 10:32 PM
I used the default
Ext.QuickTips.init();

and this is what showed up with a img title tag.

Is this something more I need to do? I played around with the min and maxWidth's but that didn't seem to do anything.

jack.slocum
3 Apr 2007, 10:57 AM
You can actually set a fix width on them (that's what most libs do).

However, I have checked in some code that should correct the p[roblem you have there.

lenzb
23 Jul 2007, 12:16 PM
Any chance you can add a configuration option to auto-size the tool tips regardless of whether or not there is a width attribute on the element (essentially just ignoring any width attribute on the element)? I'm having this problem as well, but the solution I would prefer is to have the option to have Ext automatically size the tool tip rather than having to use a workaround (either via CSS or ext:width attributes) to impact the sizing of the tool tip.

I'm now using 1.0.1a and am still having this problem. I looked in the latest 1.1RC1 code to see if anything may have changed, but it didn't look to me like anything had (though I have to admit I didn't actually test it).

For now, I've had to update the Ext code (since Ext.override isn't possible for the show function in Ext.QuickTips). It would be nice to not have to make changes to the Ext code in order to get this level of functionality (so that we don't have to worry about patching Ext upgrades in the future).

jack.slocum
23 Jul 2007, 12:30 PM
Ext.QuickTips.tagConfig.width = 'qwidth';

lenzb
23 Jul 2007, 12:47 PM
Thanks, Jack! That's perfect :)