PDA

View Full Version : [Beta 2]qtip not working in Grid



ap
12 Apr 2007, 7:23 AM
I set msgTarget to 'qtip' for all my grid columns for 'tooltop'. Sames goes for all the EditorGrid's cell validation. But nothing will come up in IE and FF.

If I set all the tooltip , blankText and all invalid text to use msgTarget:'title' things works just fine. This was not a problem in beta 1.

When I define column's tooltip like this "tooltip: {text:'This is a QuickTip', title:'Tip Title'}", with default msgTarget. 'title' tooltip will show up with text "[object object]" displayed.

It could be that I made some mistake or overlooked something. But given that it was working preior to beta2 and significant changes were made to QuickTip it could be a possible bug.

Thanks

P.S. qtips works flawlessly for all the menu bar items and form items.

mnyhuis
12 Apr 2007, 8:10 PM
I've also noticed an issue relating to the new QTips. The QTips seem to work fine when I first load my page. However I've noticed that they stop working once I have performed a Drag and Drop to another drop zone, or if the drop fails (i.e. the returning icon animation is shown).

My setup uses a tree from which I drop nodes onto a grid to populate it with rows. If I perform a Drag and Drop within the tree itself, all is well. However, as soon as I drag a node from the tree to another drop zone, or if the drop fails, QTips stop working.

I've tried various combinations to no avail. If I set enableDrag to 'false' on the tree then QTips continue to work flawlessly.

To confirm AP's post, this is a problem with Beta2 only. QTips continue to work fine under Beta1 and below.

Thanks... Michael

mnyhuis
26 Apr 2007, 4:32 AM
These Qtips problems still seem to exist in version 1. Once I perform a DnD of any sort, the QuickTips seem to stop working... Does anyone else see this problem or is it just me.

Thanks,
Michael

prophet
27 Apr 2007, 8:12 AM
I've gotten that odd object bug before... QuickTips don't seem to work right for me in ext 1... not just you.

auroraeosrose
30 Apr 2007, 7:05 AM
qtips are broken in ext 1.0 with any kind of dnd (including headers on a grid) - drag and drop is calling quicktips disable in an onmousedown event but the corresponding onmouseup that renables quicktips is NOT being called (not even sure its being registered right, I'm still fighting with venkman) - I haven't found a fix for it yet and the bug seems to be ignored...

KimH
30 Apr 2007, 7:11 AM
I'm sure that Jack and Brian has this on their todo list ;) If not then hopefully a "bump" like this will make it happen.

prophet
30 Apr 2007, 12:58 PM
Can I disable grid D&D or D&D in general? My app isn't using much of it.

mnyhuis
30 Apr 2007, 10:21 PM
qtips are broken in ext 1.0 with any kind of dnd (including headers on a grid) - drag and drop is calling quicktips disable in an onmousedown event but the corresponding onmouseup that renables quicktips is NOT being called (not even sure its being registered right, I'm still fighting with venkman) - I haven't found a fix for it yet and the bug seems to be ignored...

Thanks for the 'tip' auroraeosrose (no pun intended ;) ). I've found a workaround for QuickTips that seems to be working for me.

I added an 'enddrag' event onto my drag zone (a tree in this case) which reinitialises quicktips again at the end of a drag and drop.


tree.on('enddrag', function(){ Ext.QuickTips.enable(); });

I also have no idea why the handleMouseUp function is not working in dd/DragSource.js, but this at least gets me going for now.

Thanks,
Michael

jack.slocum
4 May 2007, 5:54 PM
This should be fixed in SVN.

tirams
7 May 2007, 8:25 AM
Is there a workaround for grid quicktips in the meantime?

mnyhuis
7 May 2007, 7:38 PM
Yes there is, it's in my earlier post.
Just apply the same 'enddrag' event to your grid...

Michael