PDA

View Full Version : Conflict with Rico library



hcervantes
12 Apr 2007, 1:05 PM
I am using Rico Live grid on my project, and I have found a conflict between Ext and Rico. I was wondering if anyone had run into the same issue. I get the following error when I make reference to the Rico library:
Error: _2[id].getRegion is not a function
Source File: http://localhost:4775/AGWMap/ext/ext-all.js
Line: 48
Error: r has no properties
Source File: http://localhost:4775/AGWMap/ext/ext-all.js
Line: 48

I only get these errors when I resize a region in a layout. As soon as I remove the rico.js reference, it works.
Can anyone help me please?
Thanks.
-Hector

sjivan
12 Apr 2007, 1:50 PM
I've had problems including Rico as well (not the same error though).

jack.slocum
12 Apr 2007, 2:05 PM
That error is generally the result of re-including YUI after Ext (instead of before) and overwriting the extensions Ext has added. There should be no conflict with Rico.

hcervantes
13 Apr 2007, 4:32 AM
Jack, does Ext use Prototype? I was thinking that might be where the conflict is, 'cuz Rico uses Protytype. Thanks.

tryanDLS
13 Apr 2007, 8:46 AM
Ext can use YUI or prototype, but unless you switched to the ext-prototype adapter, it's using yui.

bascule
12 Jun 2007, 2:50 AM
the problem with rico seems to be related to the one here:

http://extjs.com/forum/showthread.php?t=3314&highlight=resize+errors

where the problem mentioned in that post goes away after removing rico. Ive also checked and rico does change the Object.prototype to include an extend function..

hcervantes
12 Jun 2007, 4:27 AM
I fixed it by not using Rico and sticking with Ext grid. I liked the Ajax scrolling from Rico Live Grid, but that is about it. Ext is way better and cleaner to implement. I'm sure one of these days Ext will come out with the Ajax scrolling. I believe I read a thread on it.